Keyword

[Solved]K2 language not working

  • Uzi
  • Uzi's Avatar Topic Author
  • Offline
  • Premium Member
More
1 year 3 months ago #162857 by Uzi
Uzi replied the topic: K2 language not working
Are you on 3.7.3 also?

Please Log in or Create an account to join the conversation.

More
1 year 3 months ago #162865 by Krikor Boghossian
Krikor Boghossian replied the topic: K2 language not working

EDIT: Ok, I found something very weird, but interesting. I have installed the package, and if I am on the control panel page, (front page administrator) I see the strings all translated, in the menu, on the quick icons screen, but if I navigate to the actual K2 component, everything switches back, including the topmenu.


Different language files are being used across the extension.
PS. The frontend language file seems to work fine jmp.sh/u39zxBi

IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

---
JoomlaWorks
www.joomlaworks.net/

Please Log in or Create an account to join the conversation.

  • Uzi
  • Uzi's Avatar Topic Author
  • Offline
  • Premium Member
More
1 year 3 months ago #162866 by Uzi
Uzi replied the topic: K2 language not working

Krikor wrote:

EDIT: Ok, I found something very weird, but interesting. I have installed the package, and if I am on the control panel page, (front page administrator) I see the strings all translated, in the menu, on the quick icons screen, but if I navigate to the actual K2 component, everything switches back, including the topmenu.


Different language files are being used across the extension.
PS. The frontend language file seems to work fine jmp.sh/u39zxBi


I'm actually trying to get the backend translated, the front-end doesn't have to be translated for me. Weird thing is, the ini files are actually in Dutch, but it doesn't get used it seems. If I try to change the English ones to Dutch all the strings are not getting translated (you see the constant XXXXX_CONTENT_K2_NAME for example)

Please Log in or Create an account to join the conversation.

  • Uzi
  • Uzi's Avatar Topic Author
  • Offline
  • Premium Member
More
1 year 3 months ago #162879 by Uzi
Uzi replied the topic: K2 language not working
Anyone got a solution? Or do I have to wait for the K2 update or something? I am at wits end here, and I need that translation.

Please Log in or Create an account to join the conversation.

More
1 year 3 months ago #162889 by Krikor Boghossian
Krikor Boghossian replied the topic: K2 language not working
I will have to manually check the file for any issues. This is a user generated file and since 3.7 update a simple error can lead to this.
A simple edit can solve this but since this is a core hack it is not recommended.

IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

---
JoomlaWorks
www.joomlaworks.net/

Please Log in or Create an account to join the conversation.

  • Uzi
  • Uzi's Avatar Topic Author
  • Offline
  • Premium Member
More
1 year 3 months ago #162890 by Uzi
Uzi replied the topic: K2 language not working
If you could for me that would be great.

I don't mind hacking the core for now, I just want to make it work, no matter the solution.

Please Log in or Create an account to join the conversation.

  • Uzi
  • Uzi's Avatar Topic Author
  • Offline
  • Premium Member
More
1 year 3 months ago #162896 by Uzi
Uzi replied the topic: K2 language not working
If you could explain the core hack to me I will implement that so I have a working translation.

Please Log in or Create an account to join the conversation.

More
1 year 3 months ago #162901 by Krikor Boghossian
Krikor Boghossian replied the topic: K2 language not working
Under no circumstances I am endorsing a core hack
jmp.sh/R2LFrzm

This is the /libraries/joomla/language.php file. The highlighted text is the line I changed. Again, I would not use it personally.

IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

---
JoomlaWorks
www.joomlaworks.net/

Please Log in or Create an account to join the conversation.

  • Uzi
  • Uzi's Avatar Topic Author
  • Offline
  • Premium Member
More
1 year 3 months ago - 1 year 3 months ago #162902 by Uzi
Uzi replied the topic: K2 language not working
What would the solution than be? Because I am at wits end.

I'ts working. Great!!! Thank you!
Last Edit: 1 year 3 months ago by Uzi.

Please Log in or Create an account to join the conversation.

More
1 year 3 months ago #162922 by Krikor Boghossian
Krikor Boghossian replied the topic: K2 language not working
Thank you Uzi :)

IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

---
JoomlaWorks
www.joomlaworks.net/

Please Log in or Create an account to join the conversation.

Moderators: william white