Keyword

I encountered three problems...

  • Attila Szegedi
  • Attila Szegedi's Avatar Topic Author
  • Offline
  • New Member
More
3 months 3 weeks ago #172236 by Attila Szegedi
Attila Szegedi created the topic: I encountered three problems...
Hi,
I encountered three problems.
1. On the front page, the item edit form does not appear. 403 error pages are visible instead. I don't understand what the reason is because all the settings seem okay.
2. On the Admin page, when I create K2 content, I cannot select an image from the server.
3. For articles imported from Joomla content, K2 generated the tags automatically. If I record new K2 content, don't I generate tags?

Did any setting avoid my attention?
How can I resolve these problems?

Joomla 3.9.6
K2 2.9.0
PHP 7.2.0
Shape5 Vertex framework
Attachments:

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Offline
  • Administrator
  • JoomlaWorks Support Team
More
3 months 3 weeks ago #172246 by Fotis
Fotis replied the topic: I encountered three problems...
Replying...

1. Check for a file called itemform.php inside /templates/YOUR_TEMPLATE/html/com_k2/ANY_FOLDER/. If you find one, delete it.
2. Install v2.10 (dev) from github.com/getk2/k2/archive/master.zip on top of 2.9.0 and check again if the issue is resolved.
3. You need to add the tags manually. The tags created upon import are essentially the meta tags in Joomla articles. Tags in K2 are much more powerful.

Let me know.

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

  • Attila Szegedi
  • Attila Szegedi's Avatar Topic Author
  • Offline
  • New Member
More
3 months 3 weeks ago #172251 by Attila Szegedi
Attila Szegedi replied the topic: I encountered three problems...
Hi,
1. no k2 folder in html folder
2. resolved by installing v2.10
3. ok.

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Offline
  • Administrator
  • JoomlaWorks Support Team
More
3 months 3 weeks ago #172252 by Fotis
Fotis replied the topic: I encountered three problems...
So, only (1) is left. Please ensure there is no 'com_k2' folder in there, not plain 'k2'.

After the upgrade to 2.10, do you still have that issue?

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

  • Attila Szegedi
  • Attila Szegedi's Avatar Topic Author
  • Offline
  • New Member
More
3 months 3 weeks ago #172263 by Attila Szegedi
Attila Szegedi replied the topic: I encountered three problems...
There are only 2 php files in the html folder. No folder.
After installing v2.10, the problem persists
I have one more question.
Where can I set the order of the displayed content for the Latest items from (one or more) users or categories view?

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Offline
  • Administrator
  • JoomlaWorks Support Team
More
3 months 3 weeks ago #172273 by Fotis
Fotis replied the topic: I encountered three problems...
Then the error may be caused by some third party K2 plugin that is not compatible with your version PHP or the current K2 release.

As for your 2nd question, as the name implies, you can only sort blocks of latest items per category or user. You can't sort the items themselves. That menu item is primarily used to create an author's magazine style view.

If you need to display items differently, K2 Categories is your best option.

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

  • Attila Szegedi
  • Attila Szegedi's Avatar Topic Author
  • Offline
  • New Member
More
3 months 2 weeks ago #172297 by Attila Szegedi
Attila Szegedi replied the topic: I encountered three problems...
Ok, thank you for the information.

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Offline
  • Administrator
  • JoomlaWorks Support Team
More
3 months 2 weeks ago #172301 by Fotis
Fotis replied the topic: I encountered three problems...
Let me know if you solve this. Any info you can provide might help others in the future.

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

  • Attila Szegedi
  • Attila Szegedi's Avatar Topic Author
  • Offline
  • New Member
More
3 months 2 weeks ago #172329 by Attila Szegedi
Attila Szegedi replied the topic: I encountered three problems...
All right.
On the other side, I experienced the same error. I use a different template framework, and I do not use any other K2 plugins other than the K2 core add-ons on any website.

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Offline
  • Administrator
  • JoomlaWorks Support Team
More
3 months 2 weeks ago #172341 by Fotis
Fotis replied the topic: I encountered three problems...
It may be a "system" type plugin, not necessarily a K2 type plugin ;)

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

Moderators: william white

Powered by Kunena Forum