IMPORTANT MESSAGE REGARDING THE FORUM

As you may already know, the JoomlaWorks Forum is powered by Kunena (the only decent forum component for Joomla).

Unfortunately, the latest update for Kunena has seemingly broken all code snippets (old and new) in the forum.

Until this message is removed, please paste any code as regular text - in other words, don't use the [code]...[/code] tags in Kunena's post editor.

Keyword

Simple Image Gallery not working under joomla ‎4.0.0-beta7

  • Norrmann
  • Norrmann's Avatar Topic Author
  • Offline
  • New Member
More
7 months 1 week ago - 7 months 1 week ago #178348 by Norrmann
not working under joomla ‎4.0.0-beta7 was created by Norrmann
I'm preparing the transition from joomla 3.9 to J4. The simple image gallery extension works fine under Joomla 3.9.25. On a local installation of jommla 4.0.0-beta7 every call of a page containing the simple image gallery ( v4.1.0 for Joomla 4.x installed) fails with following error messages:
 
Attachments:
Last edit: 7 months 1 week ago by Norrmann.

Please Log in or Create an account to join the conversation.

More
7 months 1 week ago #178349 by Fotis
Replied by Fotis on topic not working under joomla ‎4.0.0-beta7
K2 does not work with Joomla 4 beta. because, well as the name suggests, it's beta. And constantly changing as it's been evident.

K2 will be released for Joomla 4 a few weeks after Joomla version 4.0.0 "stable" is released.

If you're working on a project that you need to ship really soon, go with Joomla 3.x.

Either way, K2 is a breeze to move between Joomla versions, which is why it supports technically 3 platforms already (Joomla 1.5, 2.5 & 3.x). Not many other extensions do that...

IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

  • Norrmann
  • Norrmann's Avatar Topic Author
  • Offline
  • New Member
More
7 months 1 week ago #178352 by Norrmann
Hi,

thank you for your reply, but I'm a bit confused. Sorry, that I didn't state it in the subject, I thought I chose the right category, sorry if not.

I'm talking about the Simple Image Gallery, where the download-button suggests, that it should work under J4 beta.

Kindest regards,

Jörg Norrmann

Please Log in or Create an account to join the conversation.

More
6 months 3 weeks ago #178425 by Fotis
GD is not enabled in your PHP setup. Enable it and the gallery will work. As for the error, the code that breaks is where server errors should be raised and apparently it's changed. I'll make sure to adapt the code accordingly.

But you'll need GD in any case, otherwise the plugin won't work at all.

IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

  • Norrmann
  • Norrmann's Avatar Topic Author
  • Offline
  • New Member
More
6 months 2 weeks ago #178542 by Norrmann
Thank you, that solved the problem.

Please Log in or Create an account to join the conversation.

More
6 months 2 weeks ago #178560 by Fotis
Great.

IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.


Powered by Kunena Forum