Keyword

Large gap before video on some browsers

  • Peter Lusmore
  • Peter Lusmore's Avatar Topic Author
  • Offline
  • New Member
More
2 years 3 months ago #175402 by Peter Lusmore
Large gap before video on some browsers was created by Peter Lusmore
On some browsers such as Safari on a Mac or iPad/iPhone there is a large gap before the video which doesn’t seem to be there when using Chrome. Can you advise how to fix this?

The page affected is bluntishambaptist.org/index.php/Ministries/virtual-church

Please Log in or Create an account to join the conversation.

More
2 years 3 months ago #175419 by JoomlaWorks
Replied by JoomlaWorks on topic Large gap before video on some browsers
Seems OK on my end. Tested on Safari on Mac (and emulated on iOS devices).

If it's not a cache issue, perhaps your template is injecting additional styling (CSS) for <video> tags for Safari.

Fotis / JoomlaWorks Support Team
---
Please search the forum before posting a new topic :)

Please Log in or Create an account to join the conversation.

  • Peter Lusmore
  • Peter Lusmore's Avatar Topic Author
  • Offline
  • New Member
More
2 years 3 months ago #175425 by Peter Lusmore
Replied by Peter Lusmore on topic Large gap before video on some browsers
I scrolled through earlier messages on the forum this afternoon and found a case where you helped someone with a problem and it referred to code being injected by some widget extension. Had a look and there was an unused module called WidgetKit still installed that was there from a previous version of the site. I disabled it and that seems to have fixed the problem. I am waiting for some feedback from other users but based on your findings I'm pretty sure that was the problem.

Please Log in or Create an account to join the conversation.

More
2 years 3 months ago #175433 by JoomlaWorks
Replied by JoomlaWorks on topic Large gap before video on some browsers
Yeah, that was it I guess. Widgetkit adds some generic CSS for video & audio tags to make them responsive, which ends up breaking any such tag that is already configured as responsive...

Fotis / JoomlaWorks Support Team
---
Please search the forum before posting a new topic :)

Please Log in or Create an account to join the conversation.


Powered by Kunena Forum