Keyword

K2 error with Phocagallery

  • Tex Long
  • Tex Long's Avatar Topic Author
  • Offline
  • New Member
More
11 years 2 months ago #68528 by Tex Long
K2 error with Phocagallery was created by Tex Long
Tried both 1.0.2 and new 2.0, same result:

Fatal error: Class 'JSite' not found in /var/www/scrcorp.com/cms/plugins/content/phocagallery.php on line 37

Uninstall the Phoca plugin, and all is well.

So... do we choose between Phoca and K2, or what?

Please Log in or Create an account to join the conversation.

More
11 years 2 months ago #68529 by Lefteris
Replied by Lefteris on topic K2 error with Phocagallery
Hi. Can you please provide some more info on this? What version of Phoca are you using? Also please check that the Phoca plugin is working properly in pages without K2 ( com_content articles etc ).

IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

---
JoomlaWorks
www.joomlaworks.net/

Please Log in or Create an account to join the conversation.

More
11 years 2 months ago #68530 by Bart Pluijms
Replied by Bart Pluijms on topic K2 error with Phocagallery
I have got the same problem with Phoca gallery.
I am using K2 v2 (prerelease) and phoca gallery 2.2.4.

Are there any solutions for this problem?

Please Log in or Create an account to join the conversation.

More
11 years 2 months ago #68531 by Lefteris
Replied by Lefteris on topic K2 error with Phocagallery
Hi. this error is caused because:
1. K2 imports all content plugins instead of only those needed for gallery and video ( SIG and AllVideos ). This is fixed in v2 final.
2. The plugin doesn't check if it is called on admin area or on site. It should not be rendered in admin as it uses the JSite class.

For more info you can read this post.

IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

---
JoomlaWorks
www.joomlaworks.net/

Please Log in or Create an account to join the conversation.

  • Tex Long
  • Tex Long's Avatar Topic Author
  • Offline
  • New Member
More
11 years 2 months ago #68532 by Tex Long
Replied by Tex Long on topic K2 error with Phocagallery
Followup: it appears to be just the plugin that causes the error. Disabling the plugin avoids the error (duhhh).

The question is, does the rest of the Phoca component work, without the plugin? Well... apparently so - I can upload pix, add them to folders, make thumbnails, and view them in a gallery. I'm not sure where the plugin comes into play, but... so far, so good.

Please Log in or Create an account to join the conversation.

  • Tex Long
  • Tex Long's Avatar Topic Author
  • Offline
  • New Member
More
11 years 2 months ago #68533 by Tex Long
Replied by Tex Long on topic K2 error with Phocagallery
1. I had checked this by moving the phocagallery to the bottom of the list, and it was still erroring. Good to know it's fixed in v2f. Thanks for the response!

Is v2f available yet?

Please Log in or Create an account to join the conversation.

More
11 years 2 months ago #68534 by Jack Sacre
Replied by Jack Sacre on topic K2 error with Phocagallery
The plugin allows you to post slideshows within articles, not just on menu items. I have also disabled it as I use the menu item option instead. would be good to see this fixed though.
Would be good to see a better way of displaying news in a module position/blog style, a bit like the mini front page 1.5 module.

Please Log in or Create an account to join the conversation.


Powered by Kunena Forum