Keyword

Save & New: Feature or Bug?

  • Tex Long
  • Tex Long's Avatar Topic Author
  • Offline
  • New Member
More
10 years 7 months ago #68881 by Tex Long
Tex Long created the topic: Save & New: Feature or Bug?
Background: In the good old days, we used to call anything that didn't work, or "worked" wrong, a bug if we could fix it, and a feature if it was either unfixable or at least not feasible to fix.

Here's what I'm seeing, in V2 pre: when adding a new item, if you pick "Save & New", all well and good, you stay in the edit screen... but when you're done, if you accidentally Save & New, then after getting a new screen, realize you have no more to add, you can't Save because there's no content, and if you Cancel, all of the preceding entries are lost.

Dammit! I went back to verify this, and it turns out that NONE of my Save & New entries are saved, even when the last one is Saved.

Am I doing something wrong?

FOLLOWUP: If you APPLY and THEN do "Save & New", the entry is saved... but I'd have to call this a workaround rather than a fix... seems like it will be easy enough to make the "Save & New" code execute the "Apply" first and then do what it's doing now, eh?

Please Log in or Create an account to join the conversation.

More
10 years 7 months ago #68882 by Simone Giacometti
Simone Giacometti replied the topic: Save & New: Feature or Bug?
Thanks for posting the workaround. I added about 20 entries yesterday and clicked on save & new every time thinking that they were being added. Today I wanted to go edit them and found that none of them were there!

This is a MAJOR bug that needs to be fixed.

Please Log in or Create an account to join the conversation.

  • Tex Long
  • Tex Long's Avatar Topic Author
  • Offline
  • New Member
More
10 years 7 months ago #68883 by Tex Long
Tex Long replied the topic: Save & New: Feature or Bug?
I was fortunate - I was testing how a multiple-item menu might work, cascading from several categories into articles within each and sub-articles from each of them, so I only put in two items/articles into the very first category and it was obvious that, duhhhh... there's still only the one "top" entry. Took me a couple of tries before I believed that so simple and obvious a function was not working.

I hope someone notices this PDQ!

Please Log in or Create an account to join the conversation.

More
10 years 7 months ago #68884 by Lefteris
Lefteris replied the topic: Save & New: Feature or Bug?
Hi. This is fixed in v2 final. Thanks for reporting.

IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

---
JoomlaWorks
www.joomlaworks.net/

Please Log in or Create an account to join the conversation.

  • Tex Long
  • Tex Long's Avatar Topic Author
  • Offline
  • New Member
More
10 years 7 months ago #68885 by Tex Long
Tex Long replied the topic: Save & New: Feature or Bug?
When and where V2 final is available?

Please Log in or Create an account to join the conversation.


Powered by Kunena Forum