Keyword

In Category view, Item titles are not acting as links

  • Ilias Antonopoulos
  • Ilias Antonopoulos's Avatar Topic Author
  • Offline
  • New Member
More
10 years 10 months ago #69389 by Ilias Antonopoulos
Ilias Antonopoulos created the topic: In Category view, Item titles are not acting as links
Hi,

First I have to say a big "thank you" for this most promising component.

I am having the following problem:
In category view, items titles are not linkable, so I cannot view the full description.

Checking the source code, I saw that the following link is produced:
< a class="k2ItemsTitle" h r e f="/index.php?option=com_k2%20%3Cb">& a m p ; view=item & a m p ; id=2%3Aitem01 & a m p ; Itemid=54 & a m p ; lang=el">item01

I guess that the problem are the '& a m p ;' in URL instead of plain &.

Is anybody else having this kind of problem?

Environment:
K2 version: 2.0.0 (Last update: June 20th, 2009)
Joomla! versions: 1.5.11, 1.5.12

Thank you

Please Log in or Create an account to join the conversation.

  • Ilias Antonopoulos
  • Ilias Antonopoulos's Avatar Topic Author
  • Offline
  • New Member
More
10 years 10 months ago #69390 by Ilias Antonopoulos
Ilias Antonopoulos replied the topic: In Category view, Item titles are not acting as links
No this is not the problem. It is more comblicated.

Please Log in or Create an account to join the conversation.

  • Ilias Antonopoulos
  • Ilias Antonopoulos's Avatar Topic Author
  • Offline
  • New Member
More
10 years 10 months ago #69391 by Ilias Antonopoulos
Ilias Antonopoulos replied the topic: In Category view, Item titles are not acting as links
OK, here is the problem.

The title of an item is acting as a link to the details of the item, only if you add a "read more" in your text, separating to INTRO and MAIN text.

But after installing K2, the read more editor's extension no longer works. Clicking it, it returns you to the main admin page.

You have to manually insert the read more by toggling to HTML view and adding:
< h r i d = " s y s t e m - r e a d m o r e " / > (without extra spaces)

Please Log in or Create an account to join the conversation.

More
10 years 10 months ago #69392 by Lefteris
Lefteris replied the topic: In Category view, Item titles are not acting as links
Hi. The editor's read more button should work. Are you getting a javascript error? Can you please post some more info on this?

IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

---
JoomlaWorks
www.joomlaworks.net/

Please Log in or Create an account to join the conversation.

  • Ilias Antonopoulos
  • Ilias Antonopoulos's Avatar Topic Author
  • Offline
  • New Member
More
10 years 10 months ago #69393 by Ilias Antonopoulos
Ilias Antonopoulos replied the topic: In Category view, Item titles are not acting as links
Strange.
After your post I tried again and the Read More works as expected.

Three days ago, when was the last time I was experimenting with K2, I had the reported problem.
And I did, not only one, but many tests. With K2's content and normal content.
No JavaScript error during the period of malfunction.

Thanks for your reply.

Please Log in or Create an account to join the conversation.

More
10 years 10 months ago #69394 by Nick
Nick replied the topic: In Category view, Item titles are not acting as links
same problem here. I'm checking this out right now. I also want to have the items in a list form of some kind. Not this crappy blog layout. This sucks the most about K2. It doesn't have this blog/list thing going on. I have to go into the code to fix this. Not bashing K2 but Zoo looks better than K2, however K2 is MUCH more powerful than Zoo. That's why i'm constantly trying to ignore zoo and keep on trying to build my goddamn one menu item with k2. Geez.

Please Log in or Create an account to join the conversation.

More
10 years 9 months ago #69395 by Michael Currey
Michael Currey replied the topic: In Category view, Item titles are not acting as links
I do but the titles do become links when you have a read more link/page break in the content of your article.

i also have the problem that once i insert a page break/read more link i can't ever delete it again. i have to delete the item and recreate it

Please Log in or Create an account to join the conversation.


Powered by Kunena Forum