Keyword

Google creating wrong sitelink to tags not working

  • Philippe
  • Philippe's Avatar Topic Author
  • Offline
  • New Member
More
3 weeks 6 days ago #170311 by Philippe
Philippe created the topic: Google creating wrong sitelink to tags not working
Hello there

I have troubles with k2's keywords creating "wrong" links. (Or maybe Joomla's?)

If I use the tag cloud module of k2 the following link is created as an example:
www.zubermedien.ch/index.php/portfolio/itemlist/tag/Print

With the link above everything works fine. However, it seems as if k2/or Joomla would also create a links as follows:
www.zubermedien.ch/index.php/component/tags/tag/print

The second link leads to a corrupted page.

The big problem is, that Google used one of those corrupted links as a sitelink in the search results!
(are those the taglink created by Joomla?)

Thanks for your help.

What I've tried so far

  • Deleted the Joomla tags
  • Please Log in or Create an account to join the conversation.

    • Fotis
    • Fotis's Avatar
    • Offline
    • Administrator
    • JoomlaWorks Support Team
    More
    3 weeks 6 days ago #170324 by Fotis
    Fotis replied the topic: Google creating wrong sitelink to tags not working
    Do this. Create a new menu in Joomla and in there add a K2 menu of "K2 Categories" type, pointing to all categories. Be careful to name the "menu alias" to something generic, e.g. "content". This will create a menu item for all K2 content to inherit a "menu alias" URL if another one does not already exist. So it should fix the multiple URLs that can be generated for tags (which is just a design flaw in Joomla's router).

    Let me know.


    If you use & love K2, please take a moment to add your review and rate it
    at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


    IMPORTANT: Please search the forum before posting a question!

    JoomlaWorks Support Team Member

    Please Log in or Create an account to join the conversation.

    • Philippe
    • Philippe's Avatar Topic Author
    • Offline
    • New Member
    More
    3 weeks 5 days ago #170338 by Philippe
    Philippe replied the topic: Google creating wrong sitelink to tags not working
    Thank you for your advice. It seems to be a workaround?
    I tried it and the result is that Google now STOPPED displaying sitelinks!

    Would it help you to get my sitemap?

    Please Log in or Create an account to join the conversation.

    • Fotis
    • Fotis's Avatar
    • Offline
    • Administrator
    • JoomlaWorks Support Team
    More
    3 weeks 5 days ago #170341 by Fotis
    Fotis replied the topic: Google creating wrong sitelink to tags not working
    It's not a workaround, it's just a way to force a "parent" menu item for any K2 content entities that don't have a distinct or inherited menu item (e.g. tags).

    Now, if you use a sitemap extension, make sure you purge any existing sitemaps and re-create them. Then request that Google re-indexes your site.

    The one I see at www.zubermedien.ch/sitemap.xml probably has outdated links.


    If you use & love K2, please take a moment to add your review and rate it
    at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


    IMPORTANT: Please search the forum before posting a question!

    JoomlaWorks Support Team Member

    Please Log in or Create an account to join the conversation.

    • Philippe
    • Philippe's Avatar Topic Author
    • Offline
    • New Member
    More
    3 weeks 4 days ago - 3 weeks 4 days ago #170344 by Philippe
    Philippe replied the topic: Google creating wrong sitelink to tags not working
    I use the following component:

    img 1https://paste.pics/2e6b88f97b13a91c3d76be1990a7a223
    img 2https://paste.pics/a339d626baf6aaca7dfef35b453a184b

    (Sitemap Generator by Marco Beierer)

    Within Search Console I made sure that Google will reindex my website. Within the next days I will check my sitemap file.
    I guess I could manually work on my sitemap to solve the problem? But that would be a stupid solution.
    Last Edit: 3 weeks 4 days ago by Philippe. Reason: Image links

    Please Log in or Create an account to join the conversation.

    • Fotis
    • Fotis's Avatar
    • Offline
    • Administrator
    • JoomlaWorks Support Team
    More
    3 weeks 4 days ago #170349 by Fotis
    Fotis replied the topic: Google creating wrong sitelink to tags not working
    Just make sure the new URLs are reflected in your sitemap correctly. Then Google's crawler will pick them up properly.


    If you use & love K2, please take a moment to add your review and rate it
    at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


    IMPORTANT: Please search the forum before posting a question!

    JoomlaWorks Support Team Member

    Please Log in or Create an account to join the conversation.

    • Philippe
    • Philippe's Avatar Topic Author
    • Offline
    • New Member
    More
    3 weeks 3 days ago - 3 weeks 3 days ago #170381 by Philippe
    Philippe replied the topic: Google creating wrong sitelink to tags not working
    The solution doesn't seem to work.
    The Links of «Flyer» and «Hochzeit» lead to corrupted pages.

    And I liked it when google used the keywords as sitelinks. That's not happening anymore. It would be great if google used the tags of k2 as sitelinks.

    This is how google sees my page. There are a lot of 404's
    www.google.ch/search?q=+site:zubermedien.ch+zubermedien&sa=X&ved=2ahUKEwjJtN7arOPeAhWDTMAKHau_CWcQrAN6BAgDEBE&biw=1362&bih=623&dpr=1.5

    Thanks for your help
    Attachments:
    Last Edit: 3 weeks 3 days ago by Philippe.

    Please Log in or Create an account to join the conversation.

    • Fotis
    • Fotis's Avatar
    • Offline
    • Administrator
    • JoomlaWorks Support Team
    More
    3 weeks 3 days ago - 3 weeks 6 hours ago #170384 by Fotis
    Fotis replied the topic: Google creating wrong sitelink to tags not working
    a) These are not valid K2 paths. Check for broken URL/links in your K2 template overrides.

    b) Additionally, the paths referenced by Google don't match your sitemap.xml file. I can only assume that if (a) does not occur that the URLs are old/cached by Google.


    If you use & love K2, please take a moment to add your review and rate it
    at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


    IMPORTANT: Please search the forum before posting a question!

    JoomlaWorks Support Team Member
    Last Edit: 3 weeks 6 hours ago by Fotis.

    Please Log in or Create an account to join the conversation.

    • Philippe
    • Philippe's Avatar Topic Author
    • Offline
    • New Member
    More
    3 weeks 2 days ago #170390 by Philippe
    Philippe replied the topic: Google creating wrong sitelink to tags not working
    Thanks for your response

    a) How do I «check for broken links» in my k2 template overrides?

    b) The strange thing is that Google changed the search results displayed for «zubermedien» every time I did changes on the website.

    Please Log in or Create an account to join the conversation.

    • Fotis
    • Fotis's Avatar
    • Offline
    • Administrator
    • JoomlaWorks Support Team
    More
    3 weeks 6 hours ago #170407 by Fotis
    Fotis replied the topic: Google creating wrong sitelink to tags not working
    Use a desktop app like Link Checker (Windows/Linux - wummel.github.io/linkchecker/ ) or Integrity (Mac - peacockmedia.software/mac/integrity/free.html ) to scan your site for dead links. These apps will report which page was the referrer for each dead link. Then you can simply take a look at the pages that produced broken links and subsequently locate their overrides to check for errors.


    If you use & love K2, please take a moment to add your review and rate it
    at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


    IMPORTANT: Please search the forum before posting a question!

    JoomlaWorks Support Team Member

    Please Log in or Create an account to join the conversation.

    Moderators: william white