Keyword

"Read More" button not behaving correctly

  • Dan Hennen
  • Dan Hennen's Avatar Topic Author
  • Offline
  • New Member
More
3 months 19 hours ago #174944 by Dan Hennen
Dan Hennen created the topic: "Read More" button not behaving correctly
Hello,

I just wrote an article and pasted it into the K2 editor. I have one photo, and only 4 paragraphs of wording.

I hit "save and close" so my "news editor" could review prior to me publishing it to the public.

The article shows up okay in the "teaser" format, but after clicking on the "read more" button, all that shows up is the photo and no text.

I'm fairly new at this, and I believe there is a quick fix.

Hoping for some suggestions.

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Away
  • Administrator
  • JoomlaWorks Support Team
More
3 months 16 hours ago #174957 by Fotis
Fotis replied the topic: "Read More" button not behaving correctly
Content in usually split in two parts: introtext and fulltext (it's a terminology that's stuck since the early days of Joomla)

If you pasted your content in the Joomla WYSIWYG editor without using the "read more" button in the editor to insert a split point, then this means you only have "introtext".

Since in K2 you have full control of the display of content, you can essentially have different display criteria per category or item "view". In other words, you can choose to show only introtext in the category listing view and in the item view choose to show both introtext and fulltext (check the K2 blog as a good example - getk2.org/blog).

In your case, I'm guessing that "introtext" is displayed in category listing views and only "fulltext" in item views. You probably did not "split" your content with the "read more" button in the Joomla WYSIWYG editor and as such, there is no "fulltext" to display in the item view.

You need to request some clarifications on how the site was setup in the first place and what you should do to have your content show up properly.

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

  • Dan Hennen
  • Dan Hennen's Avatar Topic Author
  • Offline
  • New Member
More
3 months 10 hours ago #174967 by Dan Hennen
Dan Hennen replied the topic: "Read More" button not behaving correctly
Hi.

Yes, I initially "pasted" in all the plain text first, and then later added the "read more" break.

Would it be easier to delete all the content and paste it in using several "sections" and add the "read more" in the property sequence?

I think it is currently all in "intro text".

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Away
  • Administrator
  • JoomlaWorks Support Team
More
3 months 3 hours ago #174972 by Fotis
Fotis replied the topic: "Read More" button not behaving correctly
There is an easier way for you. In K2's component settings there's this option jmp.sh/lqle6d0 that you can switch to "No", in which case the item edit form will now show 2 distinct editor blocks, one for introtext and one for fulltext.

Perhaps this is simpler for you.

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

  • Dan Hennen
  • Dan Hennen's Avatar Topic Author
  • Offline
  • New Member
More
2 months 3 weeks ago #174989 by Dan Hennen
Dan Hennen replied the topic: "Read More" button not behaving correctly
Thank you!

Yes, much easier that way. It worked!

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Away
  • Administrator
  • JoomlaWorks Support Team
More
2 months 3 weeks ago #175004 by Fotis
Fotis replied the topic: "Read More" button not behaving correctly
Great!

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.


Powered by Kunena Forum