Keyword

K2 Comments Not Working - Button Inactive.

  • David Schroeter
  • David Schroeter's Avatar Topic Author
  • Offline
  • New Member
More
4 months 2 weeks ago #175199 by David Schroeter
K2 Comments Not Working - Button Inactive. was created by David Schroeter
K2 Comments don't publish on this page - ormocexpats.com/movies/thriller/item/77-spenser-confidential-2020

The "Submit comment" button doesn't appear to work. Anyone have any ideas why this happens? I have downloaded and installed the latest K2-master.zip version from github.

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Offline
  • Administrator
  • JoomlaWorks Support Team
More
4 months 2 weeks ago #175206 by Fotis
Replied by Fotis on topic K2 Comments Not Working - Button Inactive.
There is a JS error coming from RokBox. JS breaks when you start typing a comment.

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

  • David Schroeter
  • David Schroeter's Avatar Topic Author
  • Offline
  • New Member
More
4 months 1 week ago #175218 by David Schroeter
Replied by David Schroeter on topic K2 Comments Not Working - Button Inactive.
Thanks for responding, Fotis. I have disabled RokBox but still have the same problem.

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Offline
  • Administrator
  • JoomlaWorks Support Team
More
4 months 1 week ago #175219 by Fotis
Replied by Fotis on topic K2 Comments Not Working - Button Inactive.
There is now a server-side error when you hit the "submit comment" button which is not shown on the page because the request is triggered by JS.

Some plugin is intercepting the POST request (to store the comment) and it breaks the output by Joomla.

I have a feeling you may have installed this plugin styleware.eu/store/item/67-performance-booster-for-k2 on your site at some point in the past.

If you don't find anything relevant, switch error reporting to maximum in Joomla's Global Configuration and let me know.

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

  • David Schroeter
  • David Schroeter's Avatar Topic Author
  • Offline
  • New Member
More
4 months 1 week ago #175220 by David Schroeter
Replied by David Schroeter on topic K2 Comments Not Working - Button Inactive.
Thanks Fotis. I've never used the extension you suggested. I tried disabling the K2 Multirating plugin I'm using, but that didn't help. Have switched error reporting as you requested.

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Offline
  • Administrator
  • JoomlaWorks Support Team
More
4 months 1 week ago #175223 by Fotis
Replied by Fotis on topic K2 Comments Not Working - Button Inactive.
Unfortunately it's not easy to debug on my end. Some plugin is using the "Services_JSON" class, which is obviously not loaded from any file. K2 *used* to carry that file, but that was years ago and it's been removed as it was not needed for a very long time already.

Perhaps some other K2 plugin utilized that file and if you recently upgraded K2 it was probably deleted.

In any case, scan your site for any other K2 plugins. If you have a local copy, search if the string "Services_JSON" is included in any file.

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

More
2 months 1 week ago - 2 months 1 week ago #175994 by Réda
Replied by Réda on topic K2 Comments Not Working - Button Inactive.
Hello,

it's the same for me. When clicking the send button of the comment box, nothing happens. The comment is not displayed, nor visible in the k2 comments administration, but if I try it I do get an email notification message of the comment and its content.
I've allowed the free publishing comments for anyybody in the items settings.
Here is an example of one of my items :
jakadibio.com/tous-les-articles/trois-leviers-pour-sortir-de-la-constipation
Do you have any help please ?
Last edit: 2 months 1 week ago by Réda.

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Offline
  • Administrator
  • JoomlaWorks Support Team
More
2 months 1 week ago #175998 by Fotis
Replied by Fotis on topic K2 Comments Not Working - Button Inactive.
Works just fine to me. I just added a comment here: jakadibio.com/component/k2/notre-microbiote-c-est-aussi-nous?Itemid=155

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

More
2 months 1 week ago #176007 by Réda
Replied by Réda on topic K2 Comments Not Working - Button Inactive.
Hi,
thank you for trying. I also view it in the K2 backend.

It made me try to use another browser. With my Firefox nothing happen after clicking the submit-comment button. But I tried with internet explorer and it indeed works. Which one did you use to try please ?

There's the other issue, even with internet explorer, when we click 'reply' to a comment it just sends to the top of the page, not to a comment-box. Do you have any idea ?

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Offline
  • Administrator
  • JoomlaWorks Support Team
More
2 months 1 week ago #176026 by Fotis
Replied by Fotis on topic K2 Comments Not Working - Button Inactive.
I used Chrome and I just used Firefox as well, without any issues.

I also checked for JS errors and couldn't find anything.

So perhaps there's a conflict with some Firefox plugin or something.

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.


Powered by Kunena Forum