Keyword

Joomla language switch not working after 2.10.3 update

  • bulls23
  • bulls23's Avatar Topic Author
  • Offline
  • New Member
More
2 weeks 24 minutes ago #176375 by bulls23
Hi guys,

this is my problem: the site's "lang" attribute stopped chaning after I updated to 2.10.3. The associated articles in the different languages still load and switch correctly but the "lang" attribute always remains at the standard language (in thius case "de-at") and never switches to the other language ("en-gb"). This leads to different problems on the site like parts / elements of it being in the wrong language.
I found out by using a backup from 3 months ago and updating it 'til the problem appeared and at least for me it looks like it did right after the K2 update.
Anybody aware of this?

Kind regards Alex

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Offline
  • Administrator
  • JoomlaWorks Support Team
More
1 week 6 days ago #176384 by Fotis
Do you have "Advanced SEF URLs" enabled by any chance in K2's Settings (under the SEO tab)?

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

  • bulls23
  • bulls23's Avatar Topic Author
  • Offline
  • New Member
More
1 week 6 days ago #176393 by bulls23
Both "SEF URLs" and "Custom SEF URLs" are disabled, can't find "Advanced SEF URLs".

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Offline
  • Administrator
  • JoomlaWorks Support Team
More
1 week 5 days ago #176400 by Fotis
Look in the K2 component settings please, under the SEO tab.

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

  • bulls23
  • bulls23's Avatar Topic Author
  • Offline
  • New Member
More
1 week 5 days ago - 1 week 5 days ago #176407 by bulls23
I appreciate you trying to help me, but there's simply no "Advanced" anything under the SEO tab, here's a screen shot:

Edit: how can I attach an image without it being reduced and therefore getting unreadable?

Edit2: since the forum software keeps reducing my screen shots, here's a link to the full image: we.tl/t-N9814gfegQ
Attachments:
Last edit: 1 week 5 days ago by bulls23.

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Offline
  • Administrator
  • JoomlaWorks Support Team
More
1 week 4 days ago #176408 by Fotis
The section is "Custom SEF URLs" and the relevant option is disabled. So it's not related to that.

Are you using any other third-party extensions that interface with or use K2 content?

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

  • bulls23
  • bulls23's Avatar Topic Author
  • Offline
  • New Member
More
1 week 4 days ago #176409 by bulls23
The only one I'm aware of / I could find was "Multiple categories for K2". I also tried disabling all of it but no difference. As soon as I update K2 to the latest version, the site's "lang" attribute is no longer switched.
Anything I can do to help you find the problem?

Please Log in or Create an account to join the conversation.

  • bulls23
  • bulls23's Avatar Topic Author
  • Offline
  • New Member
More
1 week 4 days ago - 1 week 4 days ago #176410 by bulls23
I have now set up two installations of the site, the only difference being the K2 version and I can provide you with the URLs and Joomla user if needed.
Last edit: 1 week 4 days ago by bulls23.

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Offline
  • Administrator
  • JoomlaWorks Support Team
More
1 week 4 days ago #176411 by Fotis
Upgrade the site with v2.10.3 to K2 v2.10.4 (dev) from: getk2.org/downloads/?f=K2_Development_Release.zip

Test again and let me know please.

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

  • bulls23
  • bulls23's Avatar Topic Author
  • Offline
  • New Member
More
1 week 4 days ago #176412 by bulls23
Judging from my quick test the "lang" attribute is switching correctly, thanks. Is this version safe to use or should I wait for the final release?

Please Log in or Create an account to join the conversation.


Powered by Kunena Forum