Keyword

PROBLEMA COL COMPONENTE >COMMENTS<

  • Massimo
  • Massimo's Avatar Topic Author
  • Offline
  • New Member
More
6 months 4 days ago #174681 by Massimo
PROBLEMA COL COMPONENTE >COMMENTS< was created by Massimo
No matter the template I use if in K2 settings I set the option for comments in ENABLED FOR REGISTERED USERS ONLY there's no way to visualize the module to insert the comment, nore for SuperUser or anybody else.
In this case a message appear saying " YOU MUST LOGIN FIRST TO WRITE COMMENTS" at bottom of k2 article.

Instead if I leave it to ENABLED TO EVERYONE the module appears with no problem.
Whould You please let me know why ?

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Offline
  • Administrator
  • JoomlaWorks Support Team
More
6 months 4 days ago #174685 by Fotis
Replied by Fotis on topic PROBLEMA COL COMPONENTE >COMMENTS<
This option locks only the comments form, not comments.

And it's there for security reasons. You probably don't want your comments to be open to everyone. If you do, make sure you enable reCaptcha and add associated keys for your domain in K2's component settings.

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

  • Massimo
  • Massimo's Avatar Topic Author
  • Offline
  • New Member
More
6 months 4 days ago #174692 by Massimo
Replied by Massimo on topic PROBLEMA COL COMPONENTE >COMMENTS<
Many thanks Fotis,
In fact what I need is only a group of registered users can post and read comments.
I do have reCaptcha enabled on the form, but reCaptcha does not resolve the matter, to me it's just an anti-spam and does not avoid anyone, even guest, to post comments.
Still I do not understand how to fix it:
- ENABLED FOR REGISTERED USERS ONLY : no comments form appears and nobody, even super user can post
- ENABLED TO EVERYONE : the form appears on any, and not on only items/categories I would like, k2 article and everyone including guests can post comments

Would you please be more clear on how to resolve the matter ?
Many thanks in advance

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Offline
  • Administrator
  • JoomlaWorks Support Team
More
6 months 4 days ago #174697 by Fotis
Replied by Fotis on topic PROBLEMA COL COMPONENTE >COMMENTS<
You need to assign the users you want to allow commenting to some K2 User Group and then edit that group's permissions and enable commenting for it's users.

Normally, K2 augments the registration in Joomla and assigns new users to the K2 User Group "Registered" which in turn allows for commenting.

For some reason this option to auto-assign new users to a K2 user group was disabled on your site.

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

  • Massimo
  • Massimo's Avatar Topic Author
  • Offline
  • New Member
More
6 months 4 days ago #174699 by Massimo
Replied by Massimo on topic PROBLEMA COL COMPONENTE >COMMENTS<
Many thanks
But Yes the group "friends" is part ok K2 groups and has enabled comments.
Yes on my site there are two extra components:
- Simple Membership component
and
- User Login One plugin

In case this does not help, please contact me directly and I'll provide you an admin userid + passw to look in the site.

Many thanks in advance

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Offline
  • Administrator
  • JoomlaWorks Support Team
More
6 months 3 days ago #174703 by Fotis
Replied by Fotis on topic PROBLEMA COL COMPONENTE >COMMENTS<
Make sure that actual users are assigned to the K2 User Group "Friends". You'll do that in K2 Users, not in Joomla Users.

If you've done that but permissions are still messed up, perhaps "Simple Membership" is causing issues. Disable it (and its associated plugins) to verify.

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.


Powered by Kunena Forum