Keyword
Please note that official support for commercial extensions & templates is provided in the Subscriber Help Desk.
Support requests should ONLY be directed there and require an active subscription plan.
This forum board is to be used for archive purposes and knowledge exchange ONLY.

SIG Pro 3.5.0 JS conflict with Virtuemart Backend

  • Björn Wichern
  • Björn Wichern's Avatar Topic Author
  • Offline
  • New Member
More
1 year 11 months ago #169725 by Björn Wichern
Hi,

I've figured out a JS conflict in Virtuemart 3.2.14 after updating SIG Pro from 3.1.0 to 3.5.0. the following JS conflict appeared:
jquery.fancybox.min.js:13 Uncaught TypeError: Cannot read property 'hash' of undefined
    at HTMLDocument.<anonymous> (jquery.fancybox.min.js:13)
    at i (jquery.min.js?0983310968bbf296a5b9448e8007f1c4:2)
    at Object.fireWith [as resolveWith] (jquery.min.js?0983310968bbf296a5b9448e8007f1c4:2)
    at Function.ready (jquery.min.js?0983310968bbf296a5b9448e8007f1c4:2)
    at HTMLDocument.K (jquery.min.js?0983310968bbf296a5b9448e8007f1c4:2)

This JS conflict disabled the tabs in the VM Backend and also the jQuery Chosen function in the Product and Category editing mode. It was impossible to save a product without losing the category. I've tried different settings in SIG 3.5.0 but could not eleminate the JS conflict. Only a downgrade to SIG Pro 3.1.0 helped.

Any ideas for this issue?

Best regards
Björn

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Away
  • Administrator
  • JoomlaWorks Support Team
More
1 year 11 months ago #169727 by Fotis
SIG Pro actually uses the latest release of Fancybox for its backend. Virtuemart uses a much older version of Fancybox which causes the conflict and breaks tabs etc. Since we've had reports from other Virtuemart users as well, I'll make sure we have a secondary option when SIGPro is used alongside Virtuemart.

I also recommend you contact the Virtuemart devs and kindly ask them to upgrade Fancybox in their code base.

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

  • Björn Wichern
  • Björn Wichern's Avatar Topic Author
  • Offline
  • New Member
More
1 year 11 months ago - 1 year 11 months ago #169728 by Björn Wichern
Replied by Björn Wichern on topic SIG Pro 3.5.0 JS conflict with Virtuemart Backend
Thanks for that information!

Just FYI, the VM forum topic:
forum.virtuemart.net/index.php?topic=141168.0

Hopefully the VM Devs will have a look at this topic.
Last edit: 1 year 11 months ago by Björn Wichern.

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Away
  • Administrator
  • JoomlaWorks Support Team
More
1 year 11 months ago #169762 by Fotis
Fingers crossed for Max to see it :)

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

More
1 year 10 months ago #170233 by Nils Ally
I see the most recent SIG Pro update is to version 3.6.0
I see on the date (XML file) that this was made 20th October 2018.
Does this mean this issue has been fixed?

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Away
  • Administrator
  • JoomlaWorks Support Team
More
1 year 10 months ago #170253 by Fotis
This is PreRelease 1, it's not the final version. The final version will be out tomorrow (if all goes to plan) and it will address the issue for the latest VM release. Which version are you currently using and has there been any response from the VM team?

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

More
1 year 10 months ago #170337 by Nils Ally
I am using 3.1, as this downgrade keeps things working.
I see you have released 3.6.0-PR2, is that ok for this problem?
VM have not responded as yet...

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Away
  • Administrator
  • JoomlaWorks Support Team
More
1 year 10 months ago #170340 by Fotis
Not yet Nils. I have delayed the update for a few more days in order to fix an issue with SIGPro on Joomla hosted on Windows Servers. I'll make sure to address the issue properly as I don't see anyone at the VM team fixing this on their side...

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

More
1 year 9 months ago #170712 by Nils Ally
Any update/news regarding this?

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Away
  • Administrator
  • JoomlaWorks Support Team
More
1 year 8 months ago #170717 by Fotis
This was resolved in v3.6.0: www.joomlaworks.net/blog/item/280-simple-image-gallery-pro-v3-6-0-released

The current version is 3.6.2.

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.


Powered by Kunena Forum