Keyword

Simple Image Gallery not working under joomla ‎4.0.0-beta7

  • Norrmann
  • Norrmann's Avatar Topic Author
  • Offline
  • New Member
More
1 month 4 days ago - 1 month 4 days ago #178348 by Norrmann
not working under joomla ‎4.0.0-beta7 was created by Norrmann
I'm preparing the transition from joomla 3.9 to J4. The simple image gallery extension works fine under Joomla 3.9.25. On a local installation of jommla 4.0.0-beta7 every call of a page containing the simple image gallery ( v4.1.0 for Joomla 4.x installed) fails with following error messages:
 
Attachments:
Last edit: 1 month 4 days ago by Norrmann.

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Offline
  • Administrator
  • JoomlaWorks Support Team
More
1 month 4 days ago #178349 by Fotis
Replied by Fotis on topic not working under joomla ‎4.0.0-beta7
K2 does not work with Joomla 4 beta. because, well as the name suggests, it's beta. And constantly changing as it's been evident.

K2 will be released for Joomla 4 a few weeks after Joomla version 4.0.0 "stable" is released.

If you're working on a project that you need to ship really soon, go with Joomla 3.x.

Either way, K2 is a breeze to move between Joomla versions, which is why it supports technically 3 platforms already (Joomla 1.5, 2.5 & 3.x). Not many other extensions do that...

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

  • Norrmann
  • Norrmann's Avatar Topic Author
  • Offline
  • New Member
More
1 month 3 days ago #178352 by Norrmann
Hi,

thank you for your reply, but I'm a bit confused. Sorry, that I didn't state it in the subject, I thought I chose the right category, sorry if not.

I'm talking about the Simple Image Gallery, where the download-button suggests, that it should work under J4 beta.

Kindest regards,

Jörg Norrmann

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Offline
  • Administrator
  • JoomlaWorks Support Team
More
2 weeks 4 days ago #178425 by Fotis
GD is not enabled in your PHP setup. Enable it and the gallery will work. As for the error, the code that breaks is where server errors should be raised and apparently it's changed. I'll make sure to adapt the code accordingly.

But you'll need GD in any case, otherwise the plugin won't work at all.

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

  • Norrmann
  • Norrmann's Avatar Topic Author
  • Offline
  • New Member
More
2 weeks 15 hours ago #178542 by Norrmann
Thank you, that solved the problem.

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Offline
  • Administrator
  • JoomlaWorks Support Team
More
1 week 6 days ago #178560 by Fotis
Great.

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.


Powered by Kunena Forum