Keyword

[SOLVED] Can't get feed to display

  • katybird
  • katybird's Avatar Topic Author
  • Offline
  • New Member
More
3 years 4 months ago #153634 by katybird
katybird created the topic: Can't get feed to display
Hi, i can't get this feed to display using Simple RSS Feed Reader. newsroom.cisco.com/data/syndication/rss2/headlinesAndNewsReleases_20.xml . It does display using the native Joomla RSS reader. I am able to show other feeds in Simple RSS, both http and https feeds but this particular one doesn't show in Simple RSS, just in native Joomla. Is there a setting somewhere that I'm missing that would let it handle that rss2 feed?

Please Log in or Create an account to join the conversation.

More
3 years 4 months ago #153637 by Teo
Teo replied the topic: Can't get feed to display
Hello,
I tried to fetch the rss feed you provided, with Simple RSS Feed Reader, and I had the following error triggered

Failed loading XML... error parsing attribute name attributes construct error Couldn't find end of Start Tag rssversion line 1 Extra content at the end of the document

By inspecting the code of the rss I noticed that indeed there is an extra whitespace between the rss and the version

<rss version="2.0">

and that is why this feed cannot be parsed.

Please Log in or Create an account to join the conversation.

  • katybird
  • katybird's Avatar Topic Author
  • Offline
  • New Member
More
3 years 4 months ago #153649 by katybird
katybird replied the topic: Can't get feed to display
I understand that the correct syntax is <rss version="2.0"> and we do end with a </rss>. I could not find any references for an <rssversion="2.0"> without whitespace. Are you sure that the existing whitespace is not being removed by the application somehow and thus causing the error because the space is missing?

Please Log in or Create an account to join the conversation.

  • katybird
  • katybird's Avatar Topic Author
  • Offline
  • New Member
More
3 years 4 months ago #153651 by katybird
katybird replied the topic: Can't get feed to display
oh, well, i submitted the feed to several online feed validators and they all said valid and Joomla native rss works but i did remove the extra space in the actual file, i couldn't see that there were actually two spaces there instead of one until i downloaded the file, but after removing that space, ie., changing from <rss version="2.0"> to <rss version="2.0"> Simple RSS is now reading the file. Thank you for your help!!

Please Log in or Create an account to join the conversation.


Powered by Kunena Forum