Keyword

RSS not rendering

  • Tobias Andersson
  • Tobias Andersson's Avatar Topic Author
  • Offline
  • New Member
More
3 years 2 months ago - 3 years 2 months ago #162599 by Tobias Andersson
RSS not rendering was created by Tobias Andersson
Why doesn't this render in the module on front-end: www.wcpt.org/rss.xml

I have tested a few RSS links, some work, others don't. Why?

Is the link wrong or anything else?

When I try this for example www.aftonbladet.se/sportbladet/rss.xml it renders on the front end but it redirect all links through my site's domain. This even though I have set this option to No in the settings.
Why?
Last edit: 3 years 2 months ago by Tobias Andersson.

Please Log in or Create an account to join the conversation.

More
3 years 2 months ago #162604 by Krikor Boghossian
Replied by Krikor Boghossian on topic RSS not rendering
Hello Tobias,

Unfortunately this is not a valid feed -> validator.w3.org/feed/check.cgi?url=http%3A%2F%2Fwww.aftonbladet.se%2Fsportbladet%2Frss.xml

You need to use only valid feeds.

IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

---
JoomlaWorks
www.joomlaworks.net/

Please Log in or Create an account to join the conversation.

  • Tobias Andersson
  • Tobias Andersson's Avatar Topic Author
  • Offline
  • New Member
More
3 years 2 months ago #162674 by Tobias Andersson
Replied by Tobias Andersson on topic RSS not rendering
This is a valid feed www.jospt.org/action/showFeed?type=etoc&feed=rss&jc=jospt

but it is not working when I add the url in a module.

Why?

Please Log in or Create an account to join the conversation.

More
3 years 2 months ago #162682 by Krikor Boghossian
Replied by Krikor Boghossian on topic RSS not rendering
Is this the only feed or are you using multiple feeds?

IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

---
JoomlaWorks
www.joomlaworks.net/

Please Log in or Create an account to join the conversation.

  • Tobias Andersson
  • Tobias Andersson's Avatar Topic Author
  • Offline
  • New Member
More
3 years 2 months ago #162693 by Tobias Andersson
Replied by Tobias Andersson on topic RSS not rendering
I use only one RSS feed in this module.


imgur.com/a/h6XH0

Please Log in or Create an account to join the conversation.

More
3 years 2 months ago #162707 by Krikor Boghossian
Replied by Krikor Boghossian on topic RSS not rendering
I need to investigate, but chances are the unknown namespace causes this issue (as per the validator).

The same's site atom feed is not valid as well.

IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

---
JoomlaWorks
www.joomlaworks.net/

Please Log in or Create an account to join the conversation.


Powered by Kunena Forum