Keyword

[SOLVED] Re: reCaptcha not working

  • Lisa Renshaw
  • Lisa Renshaw's Avatar Topic Author
  • Offline
  • New Member
More
7 years 6 months ago #64519 by Lisa Renshaw
Lisa Renshaw created the topic: [SOLVED] Re: reCaptcha not working
I have inserted the reCaptcha public and private keys in the advanced tab and captcha still does not appear. I have checked and rechecked my settings.

It appears I'm not the only one with this problem... can someone please answer this post.
The topic has been locked.
More
7 years 5 months ago - 7 years 5 months ago #64520 by Steve Scott
Steve Scott replied the topic: Re: reCaptcha not working
Hi I encountered a similar problem and found the solution as follows:

The new version of Joomla - 2.5 has a captcha form element built in - which is great. However, if you install K2 (2.5.6) this also uses the same ReCaptcha element. Unless you get the settings just right the two will conflict in strange ways. In order for the system to work you need to follow these three steps:
  1. Disable the Captcha -ReCaptcha component in the Joomla Component Manager
  2. Go to the User Manager and then to the Options (Users Configuration) and set Captcha to be "none selected"
  3. Go to the K2 configuration and enable Captcha and enter your public and private keys.

If you don't follow all three steps, then both captcha's will be used but only one will be displayed (the K2 one I think) and you will get error messages similar to this:

"The words you typed did not match the ones displayed. Please try again."

Or if you disable just the K2 Captcha then you get this error message:

Empty solution not allowed.
The topic has been locked.
More
7 years 4 months ago #64521 by Theo Prinssen
Theo Prinssen replied the topic: Re: reCaptcha not working
Hi,

I've got the same problem and followed your instruction but still the re-captcha is not showing.
You say: Disable the Captcha -ReCaptcha component in the Joomla Component Manager.
But in the component manager I don't see something with the re-captcha....so I think you ment the plugin manager.
However......re-chaptcha is still not working.

Any other solutions or suggestions?

Regards, The
The topic has been locked.
More
6 years 10 months ago #64522 by Odin Mayland
Odin Mayland replied the topic: Re: reCaptcha not working
Theo, did you get this figured out?

I disabled the captacha plugin.
Enabled and Pasted in the recaptcha keys into the K2 / Parameters / Advanced / Anti-spam Settings

But it is not showing up
The topic has been locked.
More
6 years 10 months ago #64523 by Odin Mayland
Odin Mayland replied the topic: Re: reCaptcha not working
I need to launch this site today.

anyone have any suggestions?
The topic has been locked.
More
6 years 10 months ago #64524 by Gerry Go
Gerry Go replied the topic: Re: reCaptcha not working
Has anyone figure out why the images does not appear? I got the same issue.
The topic has been locked.
More
6 years 10 months ago #64525 by Khalil
Khalil replied the topic: Re: reCaptcha not working
As-salamu alaykum,
I have resolved the problem :)
You don't have to disable anything, just to get the Captcha - ReCaptcha plugin working on K2 comment you have to follow these steps:

1 - ON www.google.com/recaptcha Go to
- USE reCAPTCHA ON YOUR SITE
- ADD Gmail account if you don't have, or log in if you have.
- Go MY ACCOUNT -> + Add a New Site
- Create a reCAPTCHA key -> ADD your Domain -> Create a Key.
- Copy (Public Key and then you will copy the Private Key)

2 - On your admin panel go to:
- Component -> K2 -> Parameters -> Comments-> Active reCaptcha -> Yes.
- Go to Component -> K2 -> Parameters -> Advanced -> Anti-spam.
- Past the two Key that you have from Google. (Public and Private Key)
-> Refresh you site and you got it ^_^

IF YOU STILL DON'T HAVE THE CAPTCHA WORKING:
Make sure you have enabled the K2 plugin and Comments on the Category options.
That should be resolving your problem.

- IF, IF that is still not working:
- Go to your site
- Click " F12 " on Google Chrom / Control+F12 (Firebugs, Firefox)
- Refresh your web site
- If you have a JavaScript errors try to find what is your problems and solutions.
- Last thing if you don't have any JS problem, You should re-install joomla xD

That is all
Thank you, your brother from Tunisia :)
The topic has been locked.
More
6 years 9 months ago #64526 by Teemu Erholm
Teemu Erholm replied the topic: Re: reCaptcha not working
I disabled the Captcha - ReCaptcha plugin as suggested, still didn't work. Then I realized I had created the recaptcha keys for a specific domain and I was working on a test site... ooppsiiee.

So I just created global keys and works fine. I even tried to enable the plugin back on and still works :P
The topic has been locked.
More
6 years 9 months ago #64527 by Robert Kelly
Robert Kelly replied the topic: Re: reCaptcha not working
Thank you Khalil, I've been trawling forums for days trying to sort my User Registration Captcha! It worked fine in Chrome, but intermittently wouldnt show in IE8, then when installed Joo Captcha instead, it displayed but kept saying "words dont match" . Did as you suggested in your post and all works fine.
The topic has been locked.
More
6 years 8 months ago - 6 years 8 months ago #64528 by danai
danai replied the topic: Re: reCaptcha not working
@ Steve Scott
Thank you very much !
This is the only that works in k2!
The topic has been locked.
Moderators: william white

Powered by Kunena Forum