IMPORTANT MESSAGE REGARDING THE FORUM

As you may already know, the JoomlaWorks Forum is powered by Kunena (the only decent forum component for Joomla).

Unfortunately, the latest update for Kunena has seemingly broken all code snippets (old and new) in the forum.

Until this message is removed, please paste any code as regular text - in other words, don't use the [code]...[/code] tags in Kunena's post editor.

Keyword

K2 image upload not working with PHP 7.4

  • Jennie Dawson
  • Jennie Dawson's Avatar Topic Author
  • Offline
  • Junior Member
More
1 year 9 months ago #174762 by Jennie Dawson
K2 image upload not working with PHP 7.4 was created by Jennie Dawson
Hi,

I moved a new site I've just completed to PHP version 7.4 but when I tried to add an image to a K2 item under the image tab, it failed to upload. I tried other images and they failed too. There was a warning message but unfortunately it was behind the 'Item saved' message so unable to read it all - see attachment.

I tried logging in from Chrome (I was using Firefox) and that didn't help.

I reverted the site back to PHP 7.2 and tried again, and it then worked fine and the image was uploaded.

Joomla version is 3.9.12
K2 version is 2.10.2

Many thanks
Jennie
Attachments:

Please Log in or Create an account to join the conversation.

More
1 year 9 months ago #174781 by Fotis
Replied by Fotis on topic K2 image upload not working with PHP 7.4
Are you using any third-party plugins for K2 perhaps?

K2 is tested and working with PHP up to 7.4.

Please Log in or Create an account to join the conversation.

  • Jennie Dawson
  • Jennie Dawson's Avatar Topic Author
  • Offline
  • Junior Member
More
1 year 9 months ago #174788 by Jennie Dawson
Replied by Jennie Dawson on topic K2 image upload not working with PHP 7.4
Hi Fotis

I've not installed any third party k2 extensions, this is just a basic site and I wanted to use k2 for a blog. I've attached the FPA report if that helps.

URL: www.mindfell.co.uk/blog

It could just be that I need to enable a PHP setting in cPanel maybe? I've also attached screenshot of settings. I enabled the 2 under 'N' as previously when I tried to switch to 7.4 on a Joomla site it didn't work at all. A search suggested this fix but I only just got around to trying it.

I have another site I can test this on which is currently running on 7.4.

Many thanks
Jennie
Attachments:

Please Log in or Create an account to join the conversation.

  • Jennie Dawson
  • Jennie Dawson's Avatar Topic Author
  • Offline
  • Junior Member
More
1 year 9 months ago #174793 by Jennie Dawson
Replied by Jennie Dawson on topic K2 image upload not working with PHP 7.4
PS I have tested on the other site and same problem occurs.

Please Log in or Create an account to join the conversation.

More
1 year 9 months ago #174795 by Fotis
Replied by Fotis on topic K2 image upload not working with PHP 7.4
You definitely need GD.

However, I wound strongly recommend installing most, only excluding the ones you KNOW you won't use, e.g. mongodb, redis, newrelic etc.

Please Log in or Create an account to join the conversation.

  • Jennie Dawson
  • Jennie Dawson's Avatar Topic Author
  • Offline
  • Junior Member
More
1 year 9 months ago #174811 by Jennie Dawson
Replied by Jennie Dawson on topic K2 image upload not working with PHP 7.4
Thank you Fotis,

Enabling the GD php extension sorted this.

I love the way you think that I would know which ones were not needed! I've searched for a list of recommended php extensions for Joomla but got nowhere. I did find one for Wordpress! Even where there are tooltips explaining it, it doesn't make me any the wiser! I tried enabling one that looked like it would be needed, but it refused saying it would conflict. I think I'd have to google every one, maybe when I have a spare afternoon, ahem!

I've never had to touch these before, the default setup always seems to have worked in the past.

Thank you for your help
Best wishes
Jennie

Please Log in or Create an account to join the conversation.

More
1 year 9 months ago - 1 year 9 months ago #174814 by Fotis
Replied by Fotis on topic K2 image upload not working with PHP 7.4
Try my suggestions. Enable them all EXCEPT redis, mongodb, newrelic, luasandbox, mysqli (that's correct, you use the newer module already which is mysqlnd), odbc.

If you get a specific conflict error, share it back with us and I'll tell you what to do.
Last edit: 1 year 9 months ago by Fotis.

Please Log in or Create an account to join the conversation.

More
11 months 3 weeks ago - 11 months 3 weeks ago #177587 by RomyS
Replied by RomyS on topic K2 image upload not working with PHP 7.4
Hi Fotis! I've the similar problem in php 7.2 and 7.3 width GD activate. (k2 2.10.3)

In IMAGE TAB: select image from the server > give me this error:
"The image was not uploaded. Please ensure that you used a valid image file and that file uploads are properly configured on your server."

Can you helpme here or i need to open other post?

Thanks for your time!
R
Last edit: 11 months 3 weeks ago by RomyS.

Please Log in or Create an account to join the conversation.

More
11 months 3 weeks ago #177589 by RomyS
Replied by RomyS on topic K2 image upload not working with PHP 7.4
UPDATE >> I updagrade to 2.10.4 and the error persist!
Probed into php 7.2 and 7.3

Please Log in or Create an account to join the conversation.

More
11 months 1 week ago #177625 by Fotis
Replied by Fotis on topic K2 image upload not working with PHP 7.4
Either some dependency is missing from your server's setup or MIME detection does not properly work. Or you have some "security" extension which stupidly blocks uploads.

Please Log in or Create an account to join the conversation.


Powered by Kunena Forum