Keyword

Videos play in articles but not in Kunena

  • Fotis
  • Fotis's Avatar
  • Offline
  • Administrator
  • JoomlaWorks Support Team
More
6 months 1 week ago #170779 by Fotis
Fotis replied the topic: Videos play in articles but not in Kunena
Maybe I missed your request on (1). It's my understanding you want users to listen to some MP3 file when browsing Kunena. If you meant you want to allow users to upload MP3 audio and have it playback on their posts, this may not be possible depending on Kunena permissions. Kunena allows attachments for sure but I doubt it allows for uploading MP3s to be directly embedded using AllVideos. In any case, ask in the Kunena forum to be sure.

As for the 2nd request, browser's (and the players included with AllVideos) are smart enough to not load the entire file. It is loaded in chunks as playback progresses. Try it. You'll see that skipping is also possible without the video being loaded entirely.

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

More
6 months 1 week ago #170799 by k2testit
k2testit replied the topic: Videos play in articles but not in Kunena

Fotis wrote: Maybe I missed your request on (1). It's my understanding you want users to listen to some MP3 file when browsing Kunena. If you meant you want to allow users to upload MP3 audio and have it playback on their posts, this may not be possible depending on Kunena permissions. Kunena allows attachments for sure but I doubt it allows for uploading MP3s to be directly embedded using AllVideos. In any case, ask in the Kunena forum to be sure.


Hello Fotis,

thanks for your reply!

Indeed I meant that users should be able to upload MP3 audio and have it playback on their posts.
Meanwhile I managed to play a LOCAL hosted MP3 audio file with AV in Kunena posts.

I had to add the extension mp3 to the list of allowed ones and to change the known settings in the kunena system plugin (message & body). Since Kunena uploads the files to media/kunena/attachments I entered that path for the LOCAL AUDIO FOLDER in AV. Afterwards the MP3 uploaded was played with AV!

But what I did NOT manage:

To make
{mp3remote}https://mydomain.tld/media/kunena/attachments/audiofile.mp3{/mp3remote}
playing the same audio file hosted on my server.

I thought with the
{mp3remote}...{/mp3remote}
tag one can make AV playing a direct URL leading to a MP3 file.
But the remote-mp3-tag leading to the same audio file on my server which can be played "locally" with the mp3-tag does not work.

Do you have any idea why it doesn´t?

As for the 2nd request, browser's (and the players included with AllVideos) are smart enough to not load the entire file. It is loaded in chunks as playback progresses. Try it. You'll see that skipping is also possible without the video being loaded entirely.


Thanks for the explaination!

By the way: I think that following text under
www.joomlaworks.net/support/docs/allvideos
is not correct:

In plain English this means that if your video exists in images/stories/videos/summer/trip_to_paris.flv and your "Local Video Folder" parameter is set to images/stories, you would simply enter {flv}summer/trip_to_paris{/flv}.


Best regards
k2testit

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Offline
  • Administrator
  • JoomlaWorks Support Team
More
6 months 1 week ago #170811 by Fotis
Fotis replied the topic: Videos play in articles but not in Kunena
For local files, you simply use {mp3}...{/mp3}. The thing is that AllVideos uses a base/root path for all local media, e.g. in /images/videos/. In your case, Kunena loads the mp3 files uploaded under /media/ which is out of the default root path used in AllVideos.

So you either need to change the default root path to point to /media/kunena/attachments/ or always use the {mp3remote}...{/mp3remote} tags.

P.S. I'll correct what you mentioned - thanks for pointing it out.

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

More
6 months 1 week ago - 6 months 1 week ago #170815 by k2testit
k2testit replied the topic: Videos play in articles but not in Kunena
Hi,

unfortunately you missed that the MP3REMOTE-TAG does not work on my site (Joomla 3.8.13 stable)!

I i. e. enter
{mp3remote}https://archive.org/download/testmp3testfile/mpthreetest.mp3{/mp3remote}

and get a broken link
https://archive.org/download/testmp3testfile/mpthreetest.mp3%7B/mp3remote

instead of an AllVideo-Player window (look screenshot attached please).

Do you have an idea WHY the remote tag does not work?

Thanks and regards
k2testit



P.S.:
Changing the order of Allvideo-Plugin (first/last) does not have any influence on the problem mentioned above!
Attachments:
Last edit: 6 months 1 week ago by k2testit.

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Offline
  • Administrator
  • JoomlaWorks Support Team
More
6 months 1 week ago #170821 by Fotis
Fotis replied the topic: Videos play in articles but not in Kunena
It's probably processed by Kunena as a link. In that case and provided you don't plan on using AllVideos elsewhere in the site, you can simply switch the root folder to point to Kunena as I mentioned already.

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

More
6 months 1 week ago #170824 by k2testit
k2testit replied the topic: Videos play in articles but not in Kunena
No, I cannot "simply switch the root folder to point to Kunena" in order to solve my problem that I cannot play any EXTERNAL MP3-files from full URLs by using the
{mp3remote} ...{/mp3remote}
-TAG.

Switching the root folder to point to Kunena - what I alread have done - only make sure that one can upload MP3-Files in kunena posts and play those locally stored files in kunena posts by help of the {mp3}-TAG.

So the question is why {mp3remote} does not work correctly in kunena?

Regards
k2testit

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Offline
  • Administrator
  • JoomlaWorks Support Team
More
6 months 1 week ago #170825 by Fotis
Fotis replied the topic: Videos play in articles but not in Kunena
Because Kunena parses the URL and converts it to an HTML link. AllVideos can't "see" the raw URL to transform it into a player.

It's an edge case to be honest...

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

More
6 months 1 week ago #170828 by k2testit
k2testit replied the topic: Videos play in articles but not in Kunena
Hi,

I found a solution for me by disabling AUTO-LINK-URLS in KUNENA-CONFIGURATION-BBCODE-Settings!
Now {mp3remote} works.

Regards
k2testit

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Offline
  • Administrator
  • JoomlaWorks Support Team
More
6 months 1 week ago #170829 by Fotis
Fotis replied the topic: Videos play in articles but not in Kunena
Great :)

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.


Powered by Kunena Forum