Keyword

Image upload error K2.7 and J3.5

  • Litho-Verlag e.K.
  • Litho-Verlag e.K.'s Avatar
  • Offline
  • Junior Member
More
3 years 6 months ago #152889 by Litho-Verlag e.K.
Litho-Verlag e.K. replied the topic: Image upload error K2.7 and J3.5
And another problem exits.

The solution above works for "create a new article" in the frontend. But if I edit an existing article, K2 opens not in a new box. It will be open in the same windows and I cannot close this window with "save" or "close".

Does anybody share my problem?

Please Log in or Create an account to join the conversation.

More
3 years 6 months ago #152902 by Krikor Boghossian
Krikor Boghossian replied the topic: Image upload error K2.7 and J3.5
Hello,

Can you try the same with the default template?
This sounds more like a template issue.

IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

---
JoomlaWorks
www.joomlaworks.net/

Please Log in or Create an account to join the conversation.

More
3 years 6 months ago #152952 by Ami Ella
Ami Ella replied the topic: Image upload error K2.7 and J3.5
Hi. I have 2 sites with K2 v2.7 on J3.5. Both are running PHP 5.6.19 on the same server.
I also confirm Miroslav solution but only for items.
It did not solve the issue in categories.
This goes for both sites.

276-279 in administrator/components/com_k2/models/item.php
Change '===' by '==' resolved the issue.

Please Log in or Create an account to join the conversation.

More
3 years 6 months ago #152967 by Krikor Boghossian
Krikor Boghossian replied the topic: Image upload error K2.7 and J3.5
Thank you Ami for your feedback :)

IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

---
JoomlaWorks
www.joomlaworks.net/

Please Log in or Create an account to join the conversation.

  • Litho-Verlag e.K.
  • Litho-Verlag e.K.'s Avatar
  • Offline
  • Junior Member
More
3 years 6 months ago #153017 by Litho-Verlag e.K.
Litho-Verlag e.K. replied the topic: Image upload error K2.7 and J3.5
No I cann't try it.

In backend Administrator/Components/com_k2 which folder?

In root/components/com_k2/templates/defalut/item.php I can not find a "===" triple to replace it.
and the same in the templates/mytempl/html/com_k2/templates/default/item.php

So where is it to fix?

Please Log in or Create an account to join the conversation.

More
3 years 6 months ago #153057 by Krikor Boghossian
Krikor Boghossian replied the topic: Image upload error K2.7 and J3.5

I fix that in item.php file (K2 administrator\components\com_k2\models) and alternated lines (around 276-279):


Or you can use the DEV version - github.com/getk2/k2/archive/master.zip

IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

---
JoomlaWorks
www.joomlaworks.net/

Please Log in or Create an account to join the conversation.

More
3 years 5 months ago #153747 by Alexander Elkin
Alexander Elkin replied the topic: Image upload error K2.7 and J3.5

Miroslav wrote: I fix that in item.php file (K2 administrator\components\com_k2\models) and alternated lines (around 276-279):
if (($files === 0 || $existingImage) && !JRequest::getBool('del_image'))
changed to
if (($files == 0 || $existingImage) && !JRequest::getBool('del_image'))

and
if ($files === 0)
changed to
if ($files == 0)


It works!

Please Log in or Create an account to join the conversation.

More
3 years 5 months ago - 3 years 5 months ago #153809 by DC10555
DC10555 replied the topic: Image upload error K2.7 and J3.5
Same issue here on 2.7 and 3.5 both fresh installations.

Thanks Miroslav! Anyone know if I can do this as an override in my template? I tried adding it to a:

TEMPLATE\html\com_k2\models\item.php

but it doesn't work..
Last edit: 3 years 5 months ago by DC10555.

Please Log in or Create an account to join the conversation.

More
3 years 5 months ago #153827 by Krikor Boghossian
Krikor Boghossian replied the topic: Image upload error K2.7 and J3.5
The model cannot be overridden, but there is no reason to worry about this.
It is already included in the DEV version and it will be included in the next stable release.

IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

---
JoomlaWorks
www.joomlaworks.net/

Please Log in or Create an account to join the conversation.

More
3 years 5 months ago #153864 by Massimo Di Primio
Massimo Di Primio replied the topic: Image upload error K2.7 and J3.5
Still having the infamous image was not uploaded. Please ensure that ....
The chunk of code in administrator/components/com_k2/models/item.php in my test installation is a bit different from the one mentioned by Miroslav.
This is what I've found at lines around 276-279.
if (($files['image']['error'] === 0 || $existingImage) && !JRequest::getBool('del_image'))
        {
                if ($files['image']['error'] === 0)
which does not correspond with the one mentioned in this forum.

I'm not using any other extensions, only K2.7 and J3.5.1 on.PHP 5.4.16
Anyway, trying to replae '===' with '==' does not seem to solve the issue.
Any idea?

-- Massix

Please Log in or Create an account to join the conversation.

Moderators: william white

Powered by Kunena Forum