Keyword

Installation impossible sous Joomla 3.922

More
2 years 1 month ago #177317 by JoomlaWorks
Replied by JoomlaWorks on topic Installation impossible sous Joomla 3.922
Can you modify the server's my.cnf? Judging from the screenshots' URLs, you're using cPanel.

Fotis / JoomlaWorks Support Team
---
Please search the forum before posting a new topic :)

Please Log in or Create an account to join the conversation.

More
2 years 1 month ago #177318 by Marc
it's a shared server (using cpanel you're right) and I don't seem to have access to this "my.cnf" ... where should be this file? ... I didn't find any with this naame

Please Log in or Create an account to join the conversation.

More
2 years 1 month ago #177319 by JoomlaWorks
Replied by JoomlaWorks on topic Installation impossible sous Joomla 3.922
Pass along the SQL error to your hosting company so they can adjust the server's my.cnf configuration accordingly (they probably need to enable innodb_large_prefix).

Fotis / JoomlaWorks Support Team
---
Please search the forum before posting a new topic :)

Please Log in or Create an account to join the conversation.

More
2 years 1 month ago #177323 by Marc
Thanks Fotis, I'll transmit to my hosting company. Usually they argue that it's a shared server son can't make any individual change ... but I hope they'll agree to do.
Have a nice day ... I'll inform if any progress for solution.

Please Log in or Create an account to join the conversation.

More
2 years 1 month ago #177331 by JoomlaWorks
Replied by JoomlaWorks on topic Installation impossible sous Joomla 3.922
You'll probably have issues with other extensions as well, so it's good to be prepared :)

Fotis / JoomlaWorks Support Team
---
Please search the forum before posting a new topic :)

Please Log in or Create an account to join the conversation.

More
2 years 1 month ago #177357 by Marc
Hi Fotis,

The DB admin had a look and his answer is the following:


"The suggested variable is already ON:

mysql> show session variables like 'innodb_large_prefix';

+
+
+

| Variable_name | Value |

+
+
+

| innodb_large_prefix | ON |

+
+
+

1 row in set (0.00 sec)

Customer must create table with:

ROW_FORMAT=DYNAMIC

E.g.


CREATE TABLE <table_name> (

... field definitions ...

) ENGINE=InnoDB ROW_FORMAT=DYNAMIC;

This is a common issues when importing from MariaDB or MySQL > 5.6"


SO WHAT CAN I DO AT THIS STAGE?

Really embarrassed not to be able to use K2

Please Log in or Create an account to join the conversation.

More
2 years 4 weeks ago #177367 by JoomlaWorks
Replied by JoomlaWorks on topic Installation impossible sous Joomla 3.922
This is the first time I hear about this.

Digging around a bit I found this old post (MySQL 5.0 is mentioned!) at the MySQL worklog site: dev.mysql.com/worklog/task/?id=8307

So it's my guess that your webhost has a weird or outdated my.cnf config. And I'm afraid I can't modify K2 for everyone just to suit your webhost.

So grab K2, extract it and edit the SQL installation file to append ROW_FORMAT=DYNAMIC at the end of each CREATE TABLE... definition.

If I were you I would changes webhosts though...

Fotis / JoomlaWorks Support Team
---
Please search the forum before posting a new topic :)

Please Log in or Create an account to join the conversation.

More
2 years 4 weeks ago #177374 by Marc
OK thanks a lot!
I'll try to do so asap.
Hope it will work ...
Have a nice day.
Marc

Please Log in or Create an account to join the conversation.

More
2 years 4 weeks ago #177375 by Marc
done ... and works!

MANY THANKS FOTIS !!!!

Please Log in or Create an account to join the conversation.

More
2 years 3 weeks ago #177386 by JoomlaWorks
Replied by JoomlaWorks on topic Installation impossible sous Joomla 3.922
Do consider the option of changing webhosts in the near future though. :)

You never know when things will break again...

Fotis / JoomlaWorks Support Team
---
Please search the forum before posting a new topic :)

Please Log in or Create an account to join the conversation.


Powered by Kunena Forum