IMPORTANT MESSAGE REGARDING THE FORUM

As you may already know, the JoomlaWorks Forum is powered by Kunena (the only decent forum component for Joomla).

Unfortunately, the latest update for Kunena has seemingly broken all code snippets (old and new) in the forum.

Until this message is removed, please paste any code as regular text - in other words, don't use the [code]...[/code] tags in Kunena's post editor.

Keyword

Module XML data not available

  • Tamara
  • Tamara's Avatar Topic Author
  • Offline
  • New Member
More
8 months 1 week ago #178047 by Tamara
Module XML data not available was created by Tamara
Hi,

Installed this module on a brand new Joomla 3 site. When I try to create the module, I get the message Module XML data not available

Can't do anything past that.

How can I fix this?

Thanks.

Please Log in or Create an account to join the conversation.

More
8 months 1 week ago #178064 by Fotis
Replied by Fotis on topic Module XML data not available
Never seen that error. It's most likely related to your setup. A screenshot would better illustrate where this occurs.

IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

More
8 months 1 week ago #178101 by STEPHAN HERBY
Replied by STEPHAN HERBY on topic Module XML data not available
Hi Fotis, I'm not sure the error is the same as @Tamara but in case, this is a screenshot of the XML ot not loaded.
(Attachments button on your topic form does not work! at least for me on Safari or Brave)
www.dropbox.com/s/m9qitdmiurih6f5/rssfeed-error-message.png?dl=1

Please Log in or Create an account to join the conversation.

More
8 months 1 week ago #178117 by Fotis
Replied by Fotis on topic Module XML data not available
Did you pass the feed from the W3C feed validator? Perhaps it's broken (e.g. contains invalid HTML or bad formatting)...

IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

More
8 months 1 week ago #178121 by STEPHAN HERBY
Replied by STEPHAN HERBY on topic Module XML data not available
Hi Fotis,
thank you for your suggestion.
Yes, and it is saying "This is a valid RSS feed."
(see here : validator.w3.org/feed/check.cgi?url=https%3A%2F%2Fmadein.nc%2Frubriques%2Fle-fil-actu%3Fformat%3Dfeed%26amp%3Btype%3Drss).

Any suggestion ?

Please Log in or Create an account to join the conversation.

More
8 months 1 week ago #178128 by Fotis
Replied by Fotis on topic Module XML data not available
Delete your site's cache to remove the cached xml. Refresh your site. Does it still occur (after a fresh fetch)?

IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

More
7 months 2 weeks ago #178293 by k2testit
Replied by k2testit on topic Module XML data not available
Hi,

I have exactly the same problem: So I cannot eben enter a valid RSS source.

I installed SIMPLE RSS Reader under Joomla! 3.9.25 Stable.

Question related to a correct running Simple RSS Reader:

Is it possible to define keywords in Simple RSS reader, which have to be present in the RSS feed, so that only those are imported, which have the keywords?

Thanks and best regards
k2testit
 
Attachments:

Please Log in or Create an account to join the conversation.

More
7 months 1 week ago #178312 by Fotis
Replied by Fotis on topic Module XML data not available
@k2testit (interesting username...) This means the module's XML file is borked or something. Re-install the module and take note if the Joomla installer displays any errors.

IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

More
7 months 1 week ago #178325 by Heather
Replied by Heather on topic Module XML data not available
Hello, I have the same issue. 
Site up to date with Joomla 3.9.25 and new download of latest version of RSS Feed Reader, with no errors on installing to site. 
Cannot create a feed, just the error message when I try and create a module. 
I have cleared the site cache and browser cache. 
 

Please Log in or Create an account to join the conversation.

More
7 months 1 week ago - 7 months 1 week ago #178331 by Fotis
Replied by Fotis on topic Module XML data not available
@Heather & @k2testit - are you by any chance on Windows based servers? Or Windows based desktops running e.g. XAMPP?

IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member
Last edit: 7 months 1 week ago by Fotis.

Please Log in or Create an account to join the conversation.


Powered by Kunena Forum