Keyword

Local AllVideo demo does not work

More
5 months 1 week ago #167817 by Teuh
Teuh created the topic: Local AllVideo demo does not work
Hello,

Several videos do not work anymore on this demo page:
demo.joomlaworks.net/allvideos

Does this mean that the plugin does not work on all browsers?

I tried on Firefox 59 and the two mp4 videos hosted on your server do not work. Only videos hosted on storage sites (Youtube ...) work.

And, still under Firefox 59 (Mac 10.11 and Windows 10), the video mp4 displays this error message: "Error code: html5_video: 4".

The case can be seen at this url (French site):
www.enquetenouvellespolicieres.fr/projet-2015-2016-en-quete-de-nouvelles-policieres/evenements-2015-2016-autour-de-l-ecriture-de-la-nouvelle-policiere

Thank you in advance for your answer.

Please Log in or Create an account to join the conversation.

More
5 months 1 week ago #167830 by Krikor Boghossian
Krikor Boghossian replied the topic: Local AllVideo demo does not work
Hello,

Unfortunately this issue lies with the video's encoding.
FF cannot display this video www.enquetenouvellespolicieres.fr/medias/videos/2016_TV7_remise_prix.mp4

Make sure that the video is being encoded with the h264 codec.

IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

---
JoomlaWorks
www.joomlaworks.net/

Please Log in or Create an account to join the conversation.

More
5 months 1 week ago - 5 months 1 week ago #167839 by Teuh
Teuh replied the topic: Local AllVideo demo does not work
Good evening,

Yes, it is encoded with h264 (*). Besides, it works with Chrome, under Mac 10.11 and Windows 10 ...

(*) mp4 (AAC - h264) encoding by Final Cut Pro X (Mac).
In addition to my answer, here is an attachment that shows that the codec of the video is H264 (this is a screenshot produced on Mac that shows the details of the video).
Attachments:
Last Edit: 5 months 1 week ago by Teuh. Reason: Further information

Please Log in or Create an account to join the conversation.

More
5 months 1 week ago #167849 by Krikor Boghossian
Krikor Boghossian replied the topic: Local AllVideo demo does not work
Unfortunately if the browser can't support it then the video cannot be streamed.
www.enquetenouvellespolicieres.fr/medias/videos/2016_TV7_remise_prix.mp4

In videos that can be streamed, the AAC codec is either last or it is not used btw
jmp.sh/7TefWqI
jmp.sh/ZF54BXh

IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

---
JoomlaWorks
www.joomlaworks.net/

Please Log in or Create an account to join the conversation.

More
5 months 1 week ago #167858 by Teuh
Teuh replied the topic: Local AllVideo demo does not work
Hello,

It is not certain that the problem comes from there (AAC - H264 instead of the opposite). Look here: www.enquetenouvellespolicieres.fr/medias/videos/1.mp4
Firefox displays this video where the encoding order is AAC - H264 (see attachment).
However, I reencoded the one for which Firefox displayed an error message. I used another software that follows the order: H264 - AAC, and the video is now displayed.
But the order does not seem to matter (AAC - H264 = H264 - AAC).
The mystery remains intact.
Thank you, anyway, for your answer.
Attachments:

Please Log in or Create an account to join the conversation.

More
5 months 1 week ago #167862 by Krikor Boghossian
Krikor Boghossian replied the topic: Local AllVideo demo does not work
I can verify the video now works on my end.
Maybe Final Cut Pro's exports have issues with cross browser compatibility.

IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

---
JoomlaWorks
www.joomlaworks.net/

Please Log in or Create an account to join the conversation.