Keyword

Unable to play any local videos with version 4.8.0

  • Jeff Steinkamp
  • Jeff Steinkamp's Avatar Topic Author
  • Offline
  • New Member
More
1 week 4 days ago #168671 by Jeff Steinkamp
Jeff Steinkamp created the topic: Unable to play any local videos with version 4.8.0
I have version 4.8.0 installed on a Joomla 2.5 site. I can play a YouTube video just fine, but I am unable to play any local mp4 videos. Here is the live site: www.ten-ten.org/index.php/resources/ft8-video

when I pull up the browser console, I get the following:
ft8-video:217 Uncaught ReferenceError: Clappr is not defined. This is with Google Chrome.

Same thing with Firefox.

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Offline
  • Administrator
  • JoomlaWorks Support Team
More
1 week 3 days ago #168674 by Fotis
Fotis replied the topic: Unable to play any local videos with version 4.8.0
Although we've stopped testing J2.5, give the dev version a try: github.com/joomlaworks/allvideos/archive/master.zip

I would also recommend solving the numerous JS issues you have on your site (missing jQueryUI etc.).

IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

---
JoomlaWorks
www.joomlaworks.net/

Please Log in or Create an account to join the conversation.

  • Jeff Steinkamp
  • Jeff Steinkamp's Avatar Topic Author
  • Offline
  • New Member
More
1 week 3 days ago #168679 by Jeff Steinkamp
Jeff Steinkamp replied the topic: Unable to play any local videos with version 4.8.0
Tried that and it did not change a thing. Is there a link to an archive version that does work with Joomla 2.5?

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Offline
  • Administrator
  • JoomlaWorks Support Team
More
1 week 3 days ago #168681 by Fotis
Fotis replied the topic: Unable to play any local videos with version 4.8.0
Try once more please, I have updated the code. The link is the same.

For reference, the check to load the correct version of the Clappr player did not account for Joomla 2.5, only Joomla 1.5. The main issue is that these 2 Joomla versions load Mootools by default and the newest releases of the Clappr player are not compatible with Mootools at all.

IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

---
JoomlaWorks
www.joomlaworks.net/

Please Log in or Create an account to join the conversation.

  • Jeff Steinkamp
  • Jeff Steinkamp's Avatar Topic Author
  • Offline
  • New Member
More
1 week 3 days ago #168682 by Jeff Steinkamp
Jeff Steinkamp replied the topic: Unable to play any local videos with version 4.8.0
Thank you very much my friend!! That did the trick. Working like a champ.

Yes, we probably need to update this site to version 3.x of Joomla, but we have a LOT of PHP, PERL and CGI stuff that is still in use and that will have to be converted to 3.x. I am a one deep shop and my background is Assembly language, FORTRAN with a bit of C and VB. So HTML, PHP and CMS is a learning work in progress..:)

Again, thank you!!

Please Log in or Create an account to join the conversation.

More
19 hours 39 minutes ago - 19 hours 32 minutes ago #168721 by Jacynthe Durocher
Jacynthe Durocher replied the topic: Unable to play any local videos with version 4.8.0
Ok I am obviously very dense today but what do I do after downloading the master? Because I just upgraded to 4.8 for a client site of mine and now I just can't see the player for the local audio file and I tried just going to the plugin and changing the folder location but no matter what I have tried so far it's not working. :(

So as a last ditch effort I want to try this master but I am just not seeing what I am supposed to do with it. Overwrite the files on the website or what? Is there a place to get back version 4.7 which worked? *** EDIT: ok I found another thread with a link to the 4.7 version which is now working. No clue why 4.8 doesn't when 4.7 does though?
Last Edit: 19 hours 32 minutes ago by Jacynthe Durocher.

Please Log in or Create an account to join the conversation.