Keyword

Cannot get AllVideos to work

  • Boy Herre
  • Boy Herre's Avatar Topic Author
  • Offline
  • New Member
More
1 week 3 days ago #170492 by Boy Herre
Boy Herre created the topic: Cannot get AllVideos to work
Hello everybody, having downloaded/installed/configured/activated the AllVideo-Plugin as told in documentation, I cannot get it to work; and I don't understand why?! The line
{swf}Anfuehren_Bande_13.swf{/swf}
won't work. It just leaves a big blank space – but doesn't show any player nor any video.
The file's path is /images/stories/videos – the file does exist in /videos.
Joomla is 3.9, Firefox is 63.03/64.

When I integrate the video via JCE it works perfectly, asking to allow Adobe Flash in the first place.

So please tell me what is wrong? What mistake could I have possibly made? Any idea anybody?
Best regards, Boy

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Offline
  • Administrator
  • JoomlaWorks Support Team
More
1 week 2 days ago #170502 by Fotis
Fotis replied the topic: Cannot get AllVideos to work
What's the URL to your site please and specifically the page where you want to load that SWF file?


If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

  • Boy Herre
  • Boy Herre's Avatar Topic Author
  • Offline
  • New Member
More
1 week 2 days ago #170513 by Boy Herre
Boy Herre replied the topic: Cannot get AllVideos to work
kreinbergsattel.com/
Backend:
kreinbergsattel.com/administrator/index.php?option=com_modules&view=module&layout=edit&id=104
File-path: images/stories/videos
Is there possibly a /slash/ lacking? I tried out, but no effect, whatsoever…
Btw: same effect when this line is not placed in a module…: {swf}Anfuehren_Bande_13.swf{/swf}
Best regards, Boy

Please Log in or Create an account to join the conversation.

  • Boy Herre
  • Boy Herre's Avatar Topic Author
  • Offline
  • New Member
More
1 week 2 days ago #170514 by Boy Herre
Boy Herre replied the topic: Cannot get AllVideos to work

Fotis wrote: What's the URL to your site please and specifically the page where you want to load that SWF file?


URL: kreinbergsattel.com/administrator/index.php?option=com_modules&view=module&layout=edit&id=104
kreinbergsattel.com

Configuration is:


Best regards, Boy
Attachments:

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Offline
  • Administrator
  • JoomlaWorks Support Team
More
1 week 2 days ago #170518 by Fotis
Fotis replied the topic: Cannot get AllVideos to work
If you see the plugin tags, you need to enable "content prepare" in the Custom HTML module you are using. See advanced options there.


If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

  • Boy Herre
  • Boy Herre's Avatar Topic Author
  • Offline
  • New Member
More
1 week 2 days ago #170520 by Boy Herre
Boy Herre replied the topic: Cannot get AllVideos to work

Fotis wrote: If you see the plugin tags, you need to enable "content prepare" in the Custom HTML module you are using. See advanced options there.


OK, I did that /thank you for a quick answer). In German this configuration looks like this:

The plugin tags now are no longer visible, but that is the only effect. The video is not visible either… What else can I do?
Best regards, Boy
Attachments:

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Offline
  • Administrator
  • JoomlaWorks Support Team
More
1 week 16 hours ago #170535 by Fotis
Fotis replied the topic: Cannot get AllVideos to work
Well, SWF's are not rendered by default in modern browsers. Perhaps the option via JCE utilizes some JS library to trigger the message to enable Adobe Flash in browsers. AllVideos simply uses the native <object> tag for flash media.

Of course it all begs the question: do you really need SWF/Flash in 2018?


If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

  • Boy Herre
  • Boy Herre's Avatar Topic Author
  • Offline
  • New Member
More
1 week 11 hours ago #170547 by Boy Herre
Boy Herre replied the topic: Cannot get AllVideos to work

Fotis wrote: Of course it all begs the question: do you really need SWF/Flash in 2018?


No; no need for swf.

But: mp4 won't work either
( kreinbergsattel.com/ ):
"Could not play video. There was a problem to load the video. Error code: html5_video:4". Take a look …

The line
{mp4}Anfuehren_Bande_13.mp4{/mp4} won't work either.

I checked the file via Filezilla/VLC which worked well; the file worked OK via Filezilla in VLC.
What now?
Boy

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Offline
  • Administrator
  • JoomlaWorks Support Team
More
1 week 11 hours ago #170548 by Fotis
Fotis replied the topic: Cannot get AllVideos to work
Use just {mp4}Anfuehren_Bande_13{/mp4}, without ".mp4". See the docs for more.


If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

  • Boy Herre
  • Boy Herre's Avatar Topic Author
  • Offline
  • New Member
More
1 week 10 hours ago #170549 by Boy Herre
Boy Herre replied the topic: Cannot get AllVideos to work
OK, this did it! It works now! Thank you!
Best regards, Boy

Please Log in or Create an account to join the conversation.