IMPORTANT MESSAGE REGARDING THE FORUM

As you may already know, the JoomlaWorks Forum is powered by Kunena (the only decent forum component for Joomla).

Unfortunately, the latest update for Kunena has seemingly broken all code snippets (old and new) in the forum.

Until this message is removed, please paste any code as regular text - in other words, don't use the [code]...[/code] tags in Kunena's post editor.

Keyword

Awesome font icons when enabling SSL

  • juan sanchez
  • juan sanchez's Avatar Topic Author
  • Offline
  • Junior Member
More
6 years 8 months ago #141940 by juan sanchez
Awesome font icons when enabling SSL was created by juan sanchez
Hi,

I've just enabled SSL on my websit with Numodusversus template. Everything is working fine except for the Font awesome icons which are not showed (see screenshot in imgur.com/JBy11HN).

Could you please give us some feedback on this?

Thanks in advance,

Regards

Please Log in or Create an account to join the conversation.

  • juan sanchez
  • juan sanchez's Avatar Topic Author
  • Offline
  • Junior Member
More
6 years 8 months ago #141955 by juan sanchez
Replied by juan sanchez on topic Awesome font icons when enabling SSL
Hi,

Is there anyone who could give us some feedback on this issue?

Thanks in advance,

Regards

Please Log in or Create an account to join the conversation.

  • Krikor Boghossian
  • Krikor Boghossian's Avatar
  • Offline
  • Platinum Member
More
6 years 8 months ago #141978 by Krikor Boghossian
Replied by Krikor Boghossian on topic Awesome font icons when enabling SSL
You are using an outdated version of the template.
Futhermore the fontawesome font is incorrectly called here: gineonline.com/templates/numodusversus/css/fontello.css

It should be nufontawesome.ttf instead of just fontawesome etc..

Please Log in or Create an account to join the conversation.

  • juan sanchez
  • juan sanchez's Avatar Topic Author
  • Offline
  • Junior Member
More
6 years 8 months ago #141979 by juan sanchez
Replied by juan sanchez on topic Awesome font icons when enabling SSL
Thanks for your answer Krikor, but I think I'm not getting your point.

I've revert back some changes I've tried for fixing this issue. If you check now my web gineonline.com you will see the system is calling cdn.joomlaworks.org/webfonts/fontawesome/css/fontello.css when showing the icons in the content higlight section and still not working when enabling SSL connection.

I guess this call function is made from variation.php file (arround line 40):

urls: [\'//cdn.nuevvo.net/webfonts/'.$font.'/css/fontello.css\']

I've also checked in the last version of the template (1.0.6) and it's the same code. Could you please give us some feedback why the SSL connection is braking the link for showing the icons?

The system is working fine when I disable the SSL connection.

Thank you very much for your support.

Regards

Please Log in or Create an account to join the conversation.

  • Krikor Boghossian
  • Krikor Boghossian's Avatar
  • Offline
  • Platinum Member
More
6 years 8 months ago #141990 by Krikor Boghossian
Replied by Krikor Boghossian on topic Awesome font icons when enabling SSL
Did you get that css file and put it in your template?
If yes, you need to either get the fonts as well, or point them towards the local copy of fontawesome (check my first post).

Please Log in or Create an account to join the conversation.

  • juan sanchez
  • juan sanchez's Avatar Topic Author
  • Offline
  • Junior Member
More
6 years 8 months ago #141993 by juan sanchez
Replied by juan sanchez on topic Awesome font icons when enabling SSL
Sorry Krikor, I don't get your point. Could you please give me a little further explanation on how are the steps and the files involved for showing the icons?

Thanks in advance,

Regards

Please Log in or Create an account to join the conversation.


Powered by Kunena Forum