IMPORTANT MESSAGE REGARDING THE FORUM

As you may already know, the JoomlaWorks Forum is powered by Kunena (the only decent forum component for Joomla).

Unfortunately, the latest update for Kunena has seemingly broken all code snippets (old and new) in the forum.

Until this message is removed, please paste any code as regular text - in other words, don't use the [code]...[/code] tags in Kunena's post editor.

Keyword

Contact form in takai

More
6 years 6 months ago #144478 by Laura
Contact form in takai was created by Laura
The contact form isn't working, it gives me 2 warnings : JUser: _ load Unable to load user with ID ..
and "You must provide at least one recipient email address"

For the first error i found a fix, but wanted to ask if adding a new superuser and change its id to the missing one, isn't a security risk?

And for the second error, no clue. It sends a copy of the message to the sender, but none of the admins get anything sent from the contact form.
I think this could be a template issue? I installed the copy I was working locally, before I had another site working on my host and the contact form worked fine - I deleted the previous site and the database, so this migration was clean.

Thanks in advance for any help or suggestions!

Please Log in or Create an account to join the conversation.

  • Krikor Boghossian
  • Krikor Boghossian's Avatar
  • Offline
  • Platinum Member
More
6 years 6 months ago #144481 by Krikor Boghossian
Replied by Krikor Boghossian on topic Contact form in takai

For the first error i found a fix, but wanted to ask if adding a new superuser and change its id to the missing one, isn't a security risk?


Not at all, since nobody knows his login name and his id (which is not the default one) then there is no risk, unless the password is 123456.

It sends a copy of the message to the sender, but none of the admins get anything sent from the contact form.


Did you change the linked user in the contact form's parameters after deleting the admin?

Please Log in or Create an account to join the conversation.

More
6 years 6 months ago #144491 by Laura
Replied by Laura on topic Contact form in takai

Did you change the linked user in the contact form's parameters after deleting the admin?

That may be the issue, but the contact form is not a module, or a plugin, where can I access those parameters?

Please Log in or Create an account to join the conversation.

  • Krikor Boghossian
  • Krikor Boghossian's Avatar
  • Offline
  • Platinum Member
More
6 years 5 months ago #144530 by Krikor Boghossian
Replied by Krikor Boghossian on topic Contact form in takai
You need to go to Components -> Contacts -> Contacts.

Please Log in or Create an account to join the conversation.


Powered by Kunena Forum