Keyword

Disable loading of magnific-popup and simple-line-icons

  • WinniePooh
  • WinniePooh's Avatar Topic Author
  • Offline
  • Senior Member
More
9 months 1 day ago #163532 by WinniePooh
WinniePooh created the topic: Disable loading of magnific-popup and simple-line-icons
Hello,

with the new 2.8 update of K2 (thank you for this one) I've noticed that K2 loads the CSS files magnific-popup.min.css and simple-line-icons.min.css from a CDN. Why needs the files to be loaded? I'm using a template override, so I can't see any changes. How can I disable the loading of these files?

Regards

Please Log in or Create an account to join the conversation.

More
9 months 1 day ago #163554 by Krikor
Krikor replied the topic: Disable loading of magnific-popup and simple-line-icons
You can alter some core files to remove the lightbox but since it is bound with frontend editing, this can lead to unexpected behaviour and some JS issues. I would not recommend performing such actions.

IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

---
JoomlaWorks
www.joomlaworks.net/

Please Log in or Create an account to join the conversation.

  • 野草工作室
  • 野草工作室's Avatar
  • Offline
  • New Member
  • 专业Joomla建站
More
3 months 2 weeks ago #166503 by 野草工作室
野草工作室 replied the topic: Disable loading of magnific-popup and simple-line-icons

Krikor wrote: You can alter some core files to remove the lightbox but since it is bound with frontend editing, this can lead to unexpected behaviour and some JS issues. I would not recommend performing such actions.


Why does K2 load more and more of these CDN resources? And can not switch to localhost resources?
I come from China, when we use K2, because of the need to load these CDNs, causing K2 to run very slowly ...

I know using CDN is to some extent to speed up loading, but for some areas may be the opposite,
Hope later updated version, at least to switch localhost load, so that can meet the needs of different situations

thank you very much


野草工作室提供专业Joomla建站服务
http://www.ycway.com

Please Log in or Create an account to join the conversation.

More
3 months 1 week ago #166574 by Eddie Hamasaki
Eddie Hamasaki replied the topic: Disable loading of magnific-popup and simple-line-icons
I have this same issue
Krikor said "You can alter some core files to remove the lightbox but since it is bound with frontend editing, this can lead to unexpected behaviour and some JS issues. I would not recommend performing such actions."

Im not using frontend editing, I even disabled it
What core files should I edit to remove magnific and simple line icons?

Please Log in or Create an account to join the conversation.

  • 野草工作室
  • 野草工作室's Avatar
  • Offline
  • New Member
  • 专业Joomla建站
More
3 months 1 week ago - 3 months 1 week ago #166583 by 野草工作室
野草工作室 replied the topic: Disable loading of magnific-popup and simple-line-icons
You can try to modify this file,
administrator/components/com_k2/helpers/html.php
Find the relevant load file and comment it

E.g
$document->addStyleSheet('https://cdnjs.cloudflare.com/ajax/libs/simple-line-icons/2.4.1/css/simple-line-icons.min.css');
Modified as such
//$document->addStyleSheet('https://cdnjs.cloudflare.com/ajax/libs/simple-line-icons/2.4.1/css/simple-line-icons.min.css');


野草工作室提供专业Joomla建站服务
http://www.ycway.com
Last Edit: 3 months 1 week ago by 野草工作室.

Please Log in or Create an account to join the conversation.

More
3 months 1 week ago #166637 by Krikor
Krikor replied the topic: Disable loading of magnific-popup and simple-line-icons
I would recommend moving this file into your local installation and change the path instead of not loading it at all.

IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

---
JoomlaWorks
www.joomlaworks.net/

Please Log in or Create an account to join the conversation.

Moderators: william white