Support will be in summer mood from 6-17 August, 2018 while the JoomlaWorks folks get some rest.
Keyword

Item rating not working

  • Stephen
  • Stephen's Avatar Topic Author
  • Offline
  • New Member
More
3 months 1 week ago #167857 by Stephen
Stephen created the topic: Item rating not working
Rating of articles does not appear to be working correctly on our site.

The first rating works OK, but all subsequent attempts to rate an article (from different computers) results in the message 'You have already rated this entry!'.

We have jquery activated in K2 settings.

Link to article:
www.alexandrapark.school/news/aps-news/899-aps-open-evening-thursday-27th-september-2018-6-8pm

Thanks.

Please Log in or Create an account to join the conversation.

More
3 months 1 week ago #167864 by Krikor Boghossian
Krikor Boghossian replied the topic: Item rating not working
Hello,

The IP is being logged. If these computers are behind the same IP then this issue might arise.

IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

---
JoomlaWorks
www.joomlaworks.net/

Please Log in or Create an account to join the conversation.

  • Stephen
  • Stephen's Avatar Topic Author
  • Offline
  • New Member
More
3 months 1 week ago #167871 by Stephen
Stephen replied the topic: Item rating not working
I thought that might be the case, so I've tried from my mobile phone, through 4G, as well as from home home and new votes are still not registering. Not a major issue, as I can simply disable ratings. I just thought it worthwhile to check if there's an easy fix.

Please Log in or Create an account to join the conversation.

More
3 months 3 days ago #167921 by Krikor Boghossian
Krikor Boghossian replied the topic: Item rating not working
Are you using a CDN?

IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

---
JoomlaWorks
www.joomlaworks.net/

Please Log in or Create an account to join the conversation.

  • Stephen
  • Stephen's Avatar Topic Author
  • Offline
  • New Member
More
3 months 2 days ago #167943 by Stephen
Stephen replied the topic: Item rating not working
You could be on to something. I believe we are on an NGINX CDN.

Thanks for your help.

Stephen

Please Log in or Create an account to join the conversation.

More
3 months 2 days ago #167949 by Krikor Boghossian
Krikor Boghossian replied the topic: Item rating not working
You 're welcome Stephen,
The CDN might be caching all requests or using a proxy. This means that all requests seem to be coming from one party. I am no sys-admin but I think a feature/setting like true client IP needs to be applied.

IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

---
JoomlaWorks
www.joomlaworks.net/

Please Log in or Create an account to join the conversation.

Moderators: william white