Keyword

K2 v2.9.0 bug in "Browse server" popup

  • nlzOne
  • nlzOne's Avatar Topic Author
  • Offline
  • New Member
More
1 year 10 months ago #170150 by nlzOne
Hello, K2 Community!

Upon clicking the "Browse server" button in Edit Item page, the popup doesn't display any files from the server. (Please see the attachment.) I only encountered this issue with the version 2.9.0 I installed in our website. Upon checking our other websites that are using lower version or using version 2.9.0 but only upgraded from previous version (I hope you get what I mean), the button and popup is working fine. I think the bug is present only to the version 2.9.0 freshly installed in Joomla CMS.

For the details of our development site, please check the list:
  • Joomla 3.9
  • K2 v2.9.0 (not upgraded from previous version but installed as v2.9.0)
  • XAMPP server
  • PHP 7
  • Windows 7

Please share your thoughts or experiences regarding the issue. Thanks!
Attachments:
The topic has been locked.
  • Fotis
  • Fotis's Avatar
  • Offline
  • Administrator
  • JoomlaWorks Support Team
More
1 year 10 months ago #170187 by Fotis
Replied by Fotis on topic K2 v2.9.0 bug in "Browse server" popup
Try the dev version (2.9.1) from github.com/getk2/k2/archive/master.zip and let me know if the error persists.

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member
The topic has been locked.
  • nlzOne
  • nlzOne's Avatar Topic Author
  • Offline
  • New Member
More
1 year 10 months ago #170280 by nlzOne
Replied by nlzOne on topic K2 v2.9.0 bug in "Browse server" popup
This is actually working. Thank you so much.

My only concern now is that 2.9.1 is just a dev version. How can I upgrade this when the 2.9.1 stable version is already available? I'm sorry if this isn't making any sense to you. It was first time to install a dev version.
The topic has been locked.
  • Fotis
  • Fotis's Avatar
  • Offline
  • Administrator
  • JoomlaWorks Support Team
More
1 year 10 months ago #170291 by Fotis
Replied by Fotis on topic K2 v2.9.0 bug in "Browse server" popup
The next stable is 2.10.0 so you'll see the update notification in Joomla ;) I'm using x.x.1 version for dev purposes. Of course it's stable as a rock, but the features I want to have so I can call it 2.10.0 are not there yet ;)

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member
The topic has been locked.
  • nlzOne
  • nlzOne's Avatar Topic Author
  • Offline
  • New Member
More
1 year 10 months ago #170303 by nlzOne
Replied by nlzOne on topic K2 v2.9.0 bug in "Browse server" popup
I see. Thanks again. More powers to K2. :)
The topic has been locked.
More
1 year 8 months ago #170798 by infographiste
Replied by infographiste on topic K2 v2.9.0 bug in "Browse server" popup
Hello,
I have installed the dev version but it's still the same for me :-(
with a fresh clean install of last joomla 3.9.1
Attachments:
The topic has been locked.
  • Fotis
  • Fotis's Avatar
  • Offline
  • Administrator
  • JoomlaWorks Support Team
More
1 year 8 months ago #170810 by Fotis
Replied by Fotis on topic K2 v2.9.0 bug in "Browse server" popup
Manually delete the folder /media/k2/assets/ and then install v2.9.1 (dev) from: github.com/getk2/k2/archive/master.zip

If you still don't see the media manager it's either a permissions issue with your webhost or some other PHP error that causes the media manager not to load. In that case, switch error reporting to maximum (in Joomla's global config) and check the modal contents again for any PHP errors shown.

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member
The topic has been locked.
More
1 year 3 months ago #172332 by Chris
Replied by Chris on topic K2 v2.9.0 bug in "Browse server" popup
Hi Fotis,
I had the same problem with nlzOne, I downloaded the version you've mentioned from Gifthub and the problem is gone.
Just a notice, the version of the k2 from Gifthub is 2.10.0
The topic has been locked.
More
1 year 3 months ago - 1 year 3 months ago #172340 by Kendall
Replied by Kendall on topic K2 v2.9.0 bug in "Browse server" popup
Yaa definitely more power to K2..Just love it www.dqfansurvey.us/
Last edit: 1 year 3 months ago by Kendall.
The topic has been locked.
  • Fotis
  • Fotis's Avatar
  • Offline
  • Administrator
  • JoomlaWorks Support Team
More
1 year 3 months ago #172347 by Fotis
Replied by Fotis on topic K2 v2.9.0 bug in "Browse server" popup
Yeah, it's now switched to v2.10.0 as I prepare the final release in the coming days.

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member
The topic has been locked.

Powered by Kunena Forum