Keyword

Category ID is not assigned when creating a category

More
5 months 2 weeks ago - 5 months 2 weeks ago #171424 by adil
adil created the topic: Category ID is not assigned when creating a category
Hi,
I create a category, it is saved, but there is no category in the tab. I go to PHP. My admin find the _k2_categories table and see the created category, and the categories that were previously created. I understand it is not assigned an ID to this category. What needs to be done to assign an id to a category? Help me please.
In attach error screenshots.
Attachments:
Last edit: 5 months 2 weeks ago by adil.

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Offline
  • Administrator
  • JoomlaWorks Support Team
More
5 months 2 weeks ago #171434 by Fotis
Fotis replied the topic: Category ID is not assigned when creating a category
If the ID is 0 it means something is broken in K2. Re-install both Joomla and K2 just to be sure.

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

More
5 months 2 weeks ago #171447 by adil
adil replied the topic: Category ID is not assigned when creating a category
Hi,
Thanks for such method! But I have a lot of data in K2 that Joomla itself. Since a very large portal! What other solutions are there for this problem?

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Offline
  • Administrator
  • JoomlaWorks Support Team
More
5 months 2 weeks ago #171454 by Fotis
Fotis replied the topic: Category ID is not assigned when creating a category
Re-install Joomla using the Joomla Update component and simply install K2 (v2.9.1 [dev] from github.com/getk2/k2/archive/master.zip ) on top of what you have already. You won't lose any data.

If you wanna be sure, just take a backup of your site and database before doing the above.

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

More
5 months 1 week ago - 5 months 1 week ago #171511 by adil
adil replied the topic: Category ID is not assigned when creating a category
Hi, Thanks for the tip.
There was a problem in the database, apparently it was not updated correctly before, the tables in the database were without the editing function. But I fixed it, and transferred it to the new Joomla and K2.
Last edit: 5 months 1 week ago by adil.

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Offline
  • Administrator
  • JoomlaWorks Support Team
More
5 months 1 week ago #171522 by Fotis
Fotis replied the topic: Category ID is not assigned when creating a category
Good to know.

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

Moderators: william white

Powered by Kunena Forum