Keyword

K2 - Add new item in this category - default category missing

  • Michael Davany
  • Michael Davany's Avatar Topic Author
  • Offline
  • New Member
More
10 months 3 weeks ago #173158 by Michael Davany
On a page displaying items from a K2 category, there is a large button at the top that reads "Add new item in this category". Clicking that button opens the K2 Edit Form, and it USED to have the default category pre-filled, but now the user has to choose the category themselves.

I have a feeling that this happened once before, and a php tweak was necessary to fix it, but I have searched and can't find anything.

I have tried different templates and different browsers, with same result, so I suspect it's a Joomla update which has changed this.

Anyone else having problems with this?

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Offline
  • Administrator
  • JoomlaWorks Support Team
More
10 months 3 weeks ago #173161 by Fotis
Check if you have an override for "itemform.php" inside /templates/YOUR_TEMPLATE/html/com_k2/default/.

If you do, delete that file and check again please.

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

  • Michael Davany
  • Michael Davany's Avatar Topic Author
  • Offline
  • New Member
More
10 months 3 weeks ago #173164 by Michael Davany
Hi Fotis, thanks for reply.
When I first discovered the problem, there were no k2 overrides under MY_TEMPLATE. I then added them in an attempt to understand the problem, but have now removed them again. Problem is still there.
Even when I specify the default Joomla beez3 template (with no overrides), the same thing happens - the "K2 Add Item" form opens, but user has to select Category themselves.

Please Log in or Create an account to join the conversation.

  • Michael Davany
  • Michael Davany's Avatar Topic Author
  • Offline
  • New Member
More
10 months 2 weeks ago #173184 by Michael Davany
I eventually solved this - I was using an out-of-date Joomla commercial template, and updating this to the most recent version solved the problem.

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Offline
  • Administrator
  • JoomlaWorks Support Team
More
10 months 2 weeks ago #173205 by Fotis
Thank you for your feedback on the issue Michael.

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

More
7 months 1 day ago #174325 by Florian Malecki
Hey guys,
unfortunately, I have the same problem, the "K2_ADD_A_NEW_ITEM_IN_THIS_CATEGORY"-Button is not selecting the current category in the editing layout...
I am using overrides in mytemplate/html, but there is no /default folder there and I deleted the "itemform.php" file in my override folder.
Michael wrote first, he used a blank template, then, he updated his template and then it works? I am using the actual version of "t3 framework".
What could be the solution for this issue?
Flo

Please Log in or Create an account to join the conversation.

  • Michael Davany
  • Michael Davany's Avatar Topic Author
  • Offline
  • New Member
More
7 months 1 day ago #174326 by Michael Davany
Hi Florian. I was using a template from Joomlashack called Mondrian. I searched and found there was an updated version of this template, and installing that cured the problem.
To identify your problem, you could try installing another template, uninstalling T3, and see if this cures it. If so, the problem might lie with T3, and you could notify the developers.
Michael

Please Log in or Create an account to join the conversation.

More
7 months 1 day ago #174327 by Florian Malecki
Hey Michael,
thanks for your quick reply and your suggestion to try another template...
@Fortis: do you know any issues with T3 concerning this problem or do you have a solution (with T3)?
Flo

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Offline
  • Administrator
  • JoomlaWorks Support Team
More
7 months 1 day ago #174332 by Fotis
T3 is just a template framework. It can't cause issues as you mention. The actual problem is just outdated K2 template overrides. Compare the parts that break (like that button) with the original override and adjust as necessary. It's not a big deal really...

Most of the times, template developers just do CSS styling on K2. So even if you deleted their overrides, 99.9% of the layout would probably remain visually unchanged.

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

More
7 months 1 day ago #174337 by Florian Malecki
Hello Fotis, thanks for the reply!
So, I tried this feature on my blank and fresh installation of joomla (3.9.14) and k2 (10.2 with german translations) without T3 – same problem: the category is not chosen after clicking "Add a new item in this category" (I created only one "test"-category with two "test"-articles...).
Could you please try this on a fresh installation for yourself? I guess, it won't work, too!
Flo

Please Log in or Create an account to join the conversation.


Powered by Kunena Forum