Keyword

files are not uploaded in item's attachments without showing any error

  • Tom Berjoy
  • Tom Berjoy 's Avatar Topic Author
  • Offline
  • New Member
More
1 week 5 days ago #173278 by Tom Berjoy
Tom Berjoy created the topic: files are not uploaded in item's attachments without showing any error
In attachment file list (backend), the file name is shown in the download link title attribute and the file name appears empty, as shown in the image. The result in frontend is a broken link that shows "file not found" and really file is not on the server.

Any fix? Thank you.

K2 v2.10.0 [Dev Build 20190915]
Joomla! 3.9.12
PHP 7.2
IIS 8
Attachments:

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Offline
  • Administrator
  • JoomlaWorks Support Team
More
2 days 17 hours ago - 2 days 17 hours ago #173332 by Fotis
Fotis replied the topic: files are not uploaded in item's attachments without showing any error
I see you're on IIS (kudos for the bravery on hosting with IIS). Make sure the PHP module "fileinfo" is loaded in your configuration. If it's not, it's the reason why the upload never actually happens.

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member
Last edit: 2 days 17 hours ago by Fotis.

Please Log in or Create an account to join the conversation.

  • Tom Berjoy
  • Tom Berjoy 's Avatar Topic Author
  • Offline
  • New Member
More
2 days 5 hours ago - 2 days 5 hours ago #173356 by Tom Berjoy
Tom Berjoy replied the topic: files are not uploaded in item's attachments without showing any error
Thank you Fotis, installed and configured the extension "fileinfo", now allows the upload and download of documents, but its extension is modified to .tmp. (the same in frontend). I think I have all my php installation well configured and other extensions upload documents without problems. What I can be omitted? Thank you
Attachments:
Last edit: 2 days 5 hours ago by Tom Berjoy .

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Offline
  • Administrator
  • JoomlaWorks Support Team
More
2 days 4 hours ago #173362 by Fotis
Fotis replied the topic: files are not uploaded in item's attachments without showing any error
As mentioned on GitHub issues, it's probably related to old accompanying libs for fileinfo or to wrong MIME detection. In any case, let's continue this over at GitHub in case it requires a change in K2.

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

  • Tom Berjoy
  • Tom Berjoy 's Avatar Topic Author
  • Offline
  • New Member
More
2 days 1 hour ago - 2 days 1 hour ago #173369 by Tom Berjoy
Tom Berjoy replied the topic: files are not uploaded in item's attachments without showing any error
ok Fotis, thank you very much
Last edit: 2 days 1 hour ago by Tom Berjoy .

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Offline
  • Administrator
  • JoomlaWorks Support Team
More
2 days 26 minutes ago #173370 by Fotis
Fotis replied the topic: files are not uploaded in item's attachments without showing any error
You're welcome :)

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

Moderators: william white

Powered by Kunena Forum