Keyword

After update to 2.10.1 the pics in the K2 module are blown with the wind

  • Litho-Verlag e.K.
  • Litho-Verlag e.K.'s Avatar Topic Author
  • Offline
  • Junior Member
More
1 week 6 days ago #173823 by Litho-Verlag e.K.
Litho-Verlag e.K. created the topic: After update to 2.10.1 the pics in the K2 module are blown with the wind
Hi
I made the update. but than only in the K2 Module the pic are disapeared and I see a broken link and the headline tag.

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Away
  • Administrator
  • JoomlaWorks Support Team
More
1 week 6 days ago #173824 by Fotis
Fotis replied the topic: After update to 2.10.1 the pics in the K2 module are blown with the wind
URL to your site?

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

  • Litho-Verlag e.K.
  • Litho-Verlag e.K.'s Avatar Topic Author
  • Offline
  • Junior Member
More
1 week 5 days ago #173842 by Litho-Verlag e.K.
Litho-Verlag e.K. replied the topic: After update to 2.10.1 the pics in the K2 module are blown with the wind
www.german-snooker-tour.de

please notice, that the first module works fine. The second modul among them doN#t shows the pics.
regards
litho

Please Log in or Create an account to join the conversation.

More
1 week 5 days ago #173849 by luken
luken replied the topic: After update to 2.10.1 the pics in the K2 module are blown with the wind
Hi. I write here because my problem could be related, and can help to resolve both cases.
In my case, I have no image in K2 item, but the module k2_content show a broken image, with alt.
Before the update, that didn't happen.
I have an override of the file default.php of the module (from before update), so the problem is not there.

site: artevial.com.ar/

Thank you

Please Log in or Create an account to join the conversation.

  • Litho-Verlag e.K.
  • Litho-Verlag e.K.'s Avatar Topic Author
  • Offline
  • Junior Member
More
1 week 4 days ago #173855 by Litho-Verlag e.K.
Litho-Verlag e.K. replied the topic: After update to 2.10.1 the pics in the K2 module are blown with the wind
hi Luken,
thank for your help, but I don't have an override, either before nor after the update.
But two things:
I restored an backup to the version 2.10.0, and there existed the problem that the pics were not visible. after updating to 2.10.1 the broken image wit alt text appears.
So Ill install the 2.9.0 version to see if this will solve my problem.
It is striking that I still have the problem with the second modul. On my startpage are the K2 modul 2 times installed. The first one work normal with the updates. The scond makes trouble.
I'll keep you informaed after installation of 2.9
regards
Litho

Please Log in or Create an account to join the conversation.

More
1 week 4 days ago - 1 week 4 days ago #173857 by luken
luken replied the topic: After update to 2.10.1 the pics in the K2 module are blown with the wind
Hi.
I think the problem is when the K2 item does not have an image.
That is why some modules work well and others do not.
Last edit: 1 week 4 days ago by luken.

Please Log in or Create an account to join the conversation.

  • Litho-Verlag e.K.
  • Litho-Verlag e.K.'s Avatar Topic Author
  • Offline
  • Junior Member
More
1 week 4 days ago #173862 by Litho-Verlag e.K.
Litho-Verlag e.K. replied the topic: After update to 2.10.1 the pics in the K2 module are blown with the wind
ok I've made some tests.
The frist k2 content Module works normal. The second k2 content modul on the same page shows the broken link ant the alt text od the headline, if the K2 item has no picture.
If the K2 item has an picture it works, until the next item comes without an pics.
So I returned to K2 2.9 and wait until I get better news.
Regards
Litho

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Away
  • Administrator
  • JoomlaWorks Support Team
More
1 week 3 days ago #173882 by Fotis
Fotis replied the topic: After update to 2.10.1 the pics in the K2 module are blown with the wind
Your overrides require some updating. Wherever you have "isset($item->image)" change it to "!empty($item->image)".

This should work and I'll make sure to add an extra check for it in the next update so it's not required in the future.

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Away
  • Administrator
  • JoomlaWorks Support Team
More
1 week 3 days ago #173884 by Fotis
Fotis replied the topic: After update to 2.10.1 the pics in the K2 module are blown with the wind
Alternatively, install 2.10.2 (dev) from github.com/getk2/k2/archive/master.zip as I've added a stricter check the module's code so you don't have to update your module template overrides.

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

More
1 week 1 day ago #173914 by luken
luken replied the topic: After update to 2.10.1 the pics in the K2 module are blown with the wind

Fotis wrote: Your overrides require some updating. Wherever you have "isset($item->image)" change it to "!empty($item->image)".

This should work and I'll make sure to add an extra check for it in the next update so it's not required in the future.


That worked for me.
Thank you.

Please Log in or Create an account to join the conversation.


Powered by Kunena Forum