Keyword

Multilanguage website with sh404sef: not translated article sef url creation

  • Leonardo Corradini
  • Leonardo Corradini's Avatar Topic Author
  • Offline
  • New Member
More
9 months 1 week ago #173947 by Leonardo Corradini
Hi,
i manage an italian website and we started translating it few months ago.

I have a lot of articles that are only in italian and not translated in english... when i look inside the SEF url manager in sh404sef (i bought your plugin) i see that those article have both an italian sef url and an english sef url generated with the same alias (having the en/ prefix before the alias and using the english language in the K2 non-sef url).
I spoke a lot with sh404sef team and they prompt me here.
I took trace of the generation of that url and here are the results:

The url is this:
www.lifeintravel.it/en/visitare-la-liguria-10-cose-da-vedere-per-innamorarsi-della-regione.html

and inside the details i have:

source (Sef)
/en/visitare-la-liguria-10-cose-da-vedere-per-innamorarsi-della-regione.html

and
Source URL (Non-SEF) index.php?option=com_k2&Itemid=4088&id=4293&lang=en&view=itemTrace
#0 /home2/zwlifein/public_html/administrator/components/com_sh404sef/classes/router.php(1036): Sh404sefHelperUrl::storeUrlSource()
#1 [internal function]: Sh404sefClassRouterInternal->buildRule(Object(Joomla\CMS\Router\SiteRouter), Object(Joomla\CMS\Uri\Uri))
#2 /home2/zwlifein/public_html/libraries/src/Router/Router.php(638): call_user_func_array(Array, Array)
#3 /home2/zwlifein/public_html/libraries/src/Router/SiteRouter.php(657): Joomla\CMS\Router\Router->processBuildRules(Object(Joomla\CMS\Uri\Uri), '')
#4 /home2/zwlifein/public_html/libraries/src/Router/Router.php(614): Joomla\CMS\Router\SiteRouter->processBuildRules(Object(Joomla\CMS\Uri\Uri))
#5 /home2/zwlifein/public_html/libraries/src/Router/Router.php(270): Joomla\CMS\Router\Router->_processBuildRules(Object(Joomla\CMS\Uri\Uri))
#6 /home2/zwlifein/public_html/libraries/src/Router/SiteRouter.php(154): Joomla\CMS\Router\Router->build('index.php?optio...')
#7 /home2/zwlifein/public_html/libraries/src/Router/Route.php(144): Joomla\CMS\Router\SiteRouter->build('index.php?optio...')
#8 /home2/zwlifein/public_html/libraries/src/Router/Route.php(93): Joomla\CMS\Router\Route::link('site', 'index.php?optio...', true, 0, false)
#9 /home2/zwlifein/public_html/plugins/sh404sefcore/sh404sefsimilarurls/sh404sefsimilarurls.php(314): Joomla\CMS\Router\Route::_('index.php?optio...')
#10 /home2/zwlifein/public_html/plugins/sh404sefcore/sh404sefsimilarurls/sh404sefsimilarurls.php(115): shFormatSimilarUrls(Array)
#11 /home2/zwlifein/public_html/plugins/sh404sefcore/sh404sefsimilarurls/sh404sefsimilarurls.php(72): shGetSimilarUrls('/en/visitare-la...', Object(Joomla\Registry\Registry))
#12 /home2/zwlifein/public_html/libraries/joomla/event/dispatcher.php(165): plgSh404sefsimilarurls('com_content.arc...', Object(stdClass), Object(Joomla\Registry\Registry), 0)
#13 /home2/zwlifein/public_html/components/com_sh404sef/views/error404/view.html.php(54): JEventDispatcher->trigger('oncontentprepar...', Array)
#14 /home2/zwlifein/public_html/libraries/src/MVC/Controller/BaseController.php(672): Sh404sefViewError404->display()
#15 /home2/zwlifein/public_html/libraries/src/MVC/Controller/BaseController.php(710): Joomla\CMS\MVC\Controller\BaseController->display()
#16 /home2/zwlifein/public_html/administrator/components/com_sh404sef/helpers/error.php(266): Joomla\CMS\MVC\Controller\BaseController->execute('')
#17 /home2/zwlifein/public_html/administrator/components/com_sh404sef/helpers/error.php(85): Sh404sefHelperError::render(Object(JException), 'The page you re...')
#18 /home2/zwlifein/public_html/administrator/components/com_sh404sef/classes/router.php(2210): Sh404sefHelperError::render404ErrorDocument(Object(JException))
#19 /home2/zwlifein/public_html/libraries/legacy/error/error.php(780): Sh404sefClassRouterInternal->sh404sefErrorPage(Object(JException))
#20 /home2/zwlifein/public_html/libraries/legacy/error/error.php(241): JError::handleCallback(Object(JException), Array)
#21 /home2/zwlifein/public_html/libraries/legacy/error/error.php(202): JError::throwError(Object(JException))
#22 /home2/zwlifein/public_html/libraries/legacy/error/error.php(277): JError::raise(1, 404, 'Item not found', NULL, true)
#23 /home2/zwlifein/public_html/components/com_k2/views/item/view.html.php(55): JError::raiseError(404, 'Item not found')
#24 /home2/zwlifein/public_html/libraries/src/MVC/Controller/BaseController.php(672): K2ViewItem->display()
#25 /home2/zwlifein/public_html/components/com_k2/controllers/controller.php(19): Joomla\CMS\MVC\Controller\BaseController->display(false, Array)
#26 /home2/zwlifein/public_html/components/com_k2/controllers/item.php(78): K2Controller->display(false, Array)
#27 /home2/zwlifein/public_html/libraries/src/MVC/Controller/BaseController.php(710): K2ControllerItem->display()
#28 /home2/zwlifein/public_html/components/com_k2/k2.php(64): Joomla\CMS\MVC\Controller\BaseController->execute('')
#29 /home2/zwlifein/public_html/libraries/src/Component/ComponentHelper.php(402): require_once('/home2/zwlifein...')
#30 /home2/zwlifein/public_html/libraries/src/Component/ComponentHelper.php(377): Joomla\CMS\Component\ComponentHelper::executeComponent('/home2/zwlifein...')
#31 /home2/zwlifein/public_html/libraries/src/Application/SiteApplication.php(194): Joomla\CMS\Component\ComponentHelper::renderComponent('com_k2')
#32 /home2/zwlifein/public_html/libraries/src/Application/SiteApplication.php(233): Joomla\CMS\Application\SiteApplication->dispatch()
#33 /home2/zwlifein/public_html/libraries/src/Application/CMSApplication.php(196): Joomla\CMS\Application\SiteApplication->doExecute()
#34 /home2/zwlifein/public_html/index.php(49): Joomla\CMS\Application\CMSApplication->execute()
#35 {main}

It seems that the source is this:
index.php?option=com_k2&Itemid=4088&id=4293&lang=en&view=itemTrace
but i don't know what itemTrace is?

Is there a way to avoid having that sef url generated?

Thanks a lot for your answer and your great component.

PS: sorry for my bad english

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Offline
  • Administrator
  • JoomlaWorks Support Team
More
9 months 1 week ago #173950 by Fotis
"Trace" just comes from the next line in what you see. It's not part of any K2 URL.

I just checked the URL you provided and it leads to a 404. Did you update your URLs?

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

  • Leonardo Corradini
  • Leonardo Corradini's Avatar Topic Author
  • Offline
  • New Member
More
9 months 1 week ago #173952 by Leonardo Corradini
Thanks Fotis for your answer.
It leads to 404 because that article is in Italian but still K2 generates an english version of that article.
My problem is that all the articles that i create in italian have an english version (non-sef K2 url) that generate url in sh404sef that have english prefix and lead to 404.
Is it normal that if i assign one language (italian) to an article, K2 still generates the other language (english) url?
It shouldn't... or am i wrong?
Thanks

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Offline
  • Administrator
  • JoomlaWorks Support Team
More
9 months 1 week ago #173954 by Fotis
All I know is that with sh404SEF disabled, K2 works as expected.

I'll have to dig deeper into the K2 for sh404SEF plugin's code for more. Let's continue this over at the helpdesk please as I may require access to your site to debug the issue.

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

More
9 months 1 week ago #173958 by Leonardo Corradini
I have no access to the help desk because I actually don't have an active subscription (it is expired) to the plugin.

Please Log in or Create an account to join the conversation.


Powered by Kunena Forum