Keyword

k2 search

  • Alexander Sahlström
  • Alexander Sahlström's Avatar Topic Author
  • Offline
  • New Member
More
1 week 5 days ago #174740 by Alexander Sahlström
Alexander Sahlström created the topic: k2 search
Hello
I get this errormessage when i try to install K2 Search module.

JInstaller: :Installera: SQL-fel Index column size too large. The maximum column size is 767 bytes.
Tillägg Installera: SQL-fel vid frågebehandling: DB-funktion misslyckades med felnummer 1709
Index column size too large. The maximum column size is 767 bytes.

What do i do?
// Alex

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Away
  • Administrator
  • JoomlaWorks Support Team
More
1 week 5 days ago #174745 by Fotis
Fotis replied the topic: k2 search
The problem is probably related to your MySQL (or MariaDB) configuration. To be exact and as described here dev.mysql.com/doc/refman/5.7/en/innodb-limits.html if "innodb_large_prefix" is set to false, this limit is imposed to databases with utf8mb4_unicode_ci collation.

Your hosting company may have set this option explicitly for backwards compatibility reasons (the default is enabled).

The other option is to download and extract the K2 zip file and edit the file /administrator/components/com_k2/install.mysql.sql replacing all instances of "CHARSET=utf8mb4 DEFAULT COLLATE=utf8mb4_unicode_ci" with "CHARSET=utf8 DEFAULT COLLATE=utf8_general_ci". Then repackage the contents you extracted into a new zip file and finally install that file in Joomla.

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.


Powered by Kunena Forum