Keyword

Time Issues for Publishing Article via comp k2

  • carlostegs
  • carlostegs's Avatar Topic Author
  • Offline
  • Senior Member
More
2 weeks 5 days ago - 2 weeks 4 days ago #176886 by carlostegs
Hello
Use Joomla 3.9.21 with PHP 7.3 and k2 component V 2.9
I have 2 sites on the same server that I updated today for Joomla 3.9.21, I'm from Brazil

First I upgraded to Joomla 3.9.20 and noticed that this was the case, then I decided to upgrade to 3.9.21 and the exact same problem occurred below

When trying to publish articles via e-mail, I have to set the time for four (4) hours before (that is, if I post at 5 pm I have to post the article at 1 pm to publish immediately) to be aired immediately otherwise it will not go on air .
It seems like an exclusive team problem only with the

I tested publishing the articles via the Joomla Editor v3.9.21, then there is no problem, the article goes live immediately.

More details to see if it helps:
- The server has the right time
- The configuration of Joomla, Global / Server is correct, this is like "Sao Paulo" (Brazil South America) which is my region.
- In the Editor of k2 when opening in New to post a new article the date that appears is correct, exactly with the time of the moment. But when saving the article it doesn't go on the air, the article is saved, but it doesn't go on the air, only if I go back in the article and go back to the schedule for four (4) hours ago.

Does anyone know why this occurs with the k2 component?

I look forward to a possible help

Thank you

Health
Success always
Carlostegs
BRAZIL
Last edit: 2 weeks 4 days ago by carlostegs.

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Offline
  • Administrator
  • JoomlaWorks Support Team
More
2 weeks 3 days ago #176894 by Fotis
a) K2 v2.9 is many versions back. Update to K2 v2.10.x.
b) This may be related to a server issue. What's the GMT offset to your location? Is it 4 hours?

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

  • carlostegs
  • carlostegs's Avatar Topic Author
  • Offline
  • Senior Member
More
2 weeks 3 days ago #176897 by carlostegs
Replied by carlostegs on topic Time Issues for Publishing Article via comp k2
Fotis
Hello!
All well?

I just followed your advice and upgraded to K2 VERSION 2.10.3 on both sites.
This problem really corrected on both sites, now this is ok.

1 NEW PROBLEM: Only one of them has a problem with the Image part of not finding the Image Database that you have on the site, the Image button / search server
It seems that the link searches for images on the server is not finding the images.
Do you have any idea what I can do?

As for my region it is Brazil and there is a difference of only 3 hours, but the problem that was in the country is the difference of 4 hours as I said.

I look forward to a FeedBack on this image link?

Awaiting

Thank you
Cheers
Much Success
Jose Carlos

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Offline
  • Administrator
  • JoomlaWorks Support Team
More
2 weeks 1 day ago #176903 by Fotis
My guess is that there are lots of images in the main /images folder and the server takes a while to list all of them. If the listing never happens, it's possible that some PHP limit is reached. If you can increase your site's memory_limit value in PHP, do so and test again.

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

  • carlostegs
  • carlostegs's Avatar Topic Author
  • Offline
  • Senior Member
More
2 weeks 1 day ago #176918 by carlostegs
Replied by carlostegs on topic Time Issues for Publishing Article via comp k2
Fotis
Hello

Thanks for the tips, but come on

Our server is dedicated and exclusive to our website.
Some values of our php version 7.3
max_execution_time 300
post_max_size 128M
upload_max_filesize 128M
memory_limit 256M

Do you think I should change any of these values?

Now among what you reported, there is a detail, we have many images, as it is a news site and there are more than 200 thousand news on it and I believe that around 20 thousand images

A question? When this type of error occurs, can I install a previous version, like k2 version 2.10.2 or version.2.10.1 on top of version 2.10.3?

I await your analysis

Thank you
Success always
Jose Carlos

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Offline
  • Administrator
  • JoomlaWorks Support Team
More
2 weeks 4 hours ago #176926 by Fotis
Look, if you have 20,000 images on /images, yes, do expect the file manager to take long to respond or not respond at all. In any case, this is beyond the support I can offer as it's a 3rd party script (elFinder). What I know is that 2.10.3 uses a far newer (and supposedly better) version of what was in 2.9.

For the record, it's easy to debug issues with elFinder. Just open your browser's console and check for any errors.

Having a dedicated server also doesn't say much for a large site. A 256M memory_limit may be low for your needs, especially if PHP is running through PHP-FPM and even more so if you have other sites too. A typical WP site now needs baseline 512M. I don't see why a Joomla site wouldn't...

You can downgrade if you want, things will most likely not break, but make sure you take a backup just in case.

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

  • carlostegs
  • carlostegs's Avatar Topic Author
  • Offline
  • Senior Member
More
1 week 6 days ago - 1 week 6 days ago #176935 by carlostegs
Replied by carlostegs on topic Time Issues for Publishing Article via comp k2
Fotis
Hello

Just a correction:
My apologies
When I say that it has 20,000 images it is not in the Joomla image folder but in the K2 folder, the vast majority are images of the same.
Does that influence anything?

As I understand it, you advise me to increase the memory_limit from 256M to 512M am I correct?

Thank you
Success always
Jose Carlos
Last edit: 1 week 6 days ago by carlostegs.

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Offline
  • Administrator
  • JoomlaWorks Support Team
More
1 week 4 days ago #176939 by Fotis
Increasing the memory limit is one option. However, do use your browser's console and check for any errors when opening elFinder. It could be some PHP warning or notice being injected into Joomla responses by some other extension (e.g. an outdated system plugin) and as such breaking elFinder's JSON data transmission. I'm now leaning towards this as the most potential reason for elFinder not working on your site. In that case, the fix would be simple. Just switch error reporting to off in Joomla's Global Configuration.

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.


Powered by Kunena Forum