Keyword

Font End Users menu not displays properly

  • guida
  • guida's Avatar Topic Author
  • Offline
  • Junior Member
More
1 month 1 week ago - 1 month 1 week ago #177613 by guida
I have front end users enabled. theuy can edit articles and i publish them after moderation. It is working fine, except for a detail: when i user opens the link to view his own items these items are displayed, but the side panel disappears, so there is no navigation and the only option is to go back in the browser.

I send you two attached files.
One with the right display and the other with the wrong display that ONLY happens in the view own articles link

I have tried many things but i don't want to mess it more. do you have a clue?

I running Joomla! 3.9.23 , php7.3 cache and gzip disconnect and I only have to fix this to launch the site.

I appreciate your help
Attachments:
Last edit: 1 month 1 week ago by guida.

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Offline
  • Administrator
  • JoomlaWorks Support Team
More
1 month 1 week ago #177660 by Fotis
Replied by Fotis on topic Font End Users menu not displays properly
This is a templating issue. The right side column is simply not loading any modules there. My guess is the modules in there are set to specific pages and not all. Since the user pages don't have menu links, you need to re-work your right column modules setup.

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

  • guida
  • guida's Avatar Topic Author
  • Offline
  • Junior Member
More
1 month 1 week ago #177678 by guida
Replied by guida on topic Font End Users menu not displays properly
Hmm, i am not sure i understood.

I made some changes and still it is not right:

1. To avoid template interference, i have placed the k2 user box in the right-top side and know the problem is gone. new items, profile and personal page are in the menu. beautiful.

BUT

2. the k2 module is set to public (not registered).
fine now, but when the user logs in it shows all the items of his own account and PLUS a button that links to edit module, to personal account and position. by clicking on this botton the user can change the position!!! (see pics)
So how to remove the botton?!?

3. In the backend registered user permission and both in joomla users and k2 users are set as shows in the image( permissions to create, eliminate and edit)
The options edit state is BLOCKED my the system. I guess this is an error.
Could you tell why that button now shows up on the frontend? and why edit estate is blocked by the system in the backend?

I will appreciate your answer,

Ana
Attachments:

Please Log in or Create an account to join the conversation.

  • guida
  • guida's Avatar Topic Author
  • Offline
  • Junior Member
More
4 weeks 12 hours ago #177713 by guida
Replied by guida on topic Font End Users menu not displays properly
Well,

after several trials the module k2 user is still sohwing several errors.

1. I have a user menu with links to authenctication and user profile.
2. I have a k2 user box assigned to all pages. when the user logs in he goes directly to edit profile page. so fine.

errors
3. the edit profile page looks strange. i guess it is the css . see image

4. if the user clicks on My Page to edit items, he loses the navigation of module k2 user. See image. This happens almost all the time, but somethings it keeps the navigation. so many times is ok, many times it is not. I can´t figure out why.

5. This happened before after i set on the cache. it is the same with or without cache on.

6. when a user clicks on edit new item, a line of error appears on the top of the page and it disappears really quickly so i am not sure of the exact link. This does not cause problem, but still is and error.
Again, it doesnt show all the time, but as far i can figure the error is on system plugin k2.php line 702:
$getK2CacheHeaders = json_decode(trim($getK2CacheHeaders[1]));

so for all these reasons, it is not the template but some function of the k2 that is not working.

I ask:

Should i have the user menu on with 2 itens: authentication (public) and edit profile (registered)?
(the get duplicated it the k2 user box)

Well i am looking forward a solution, this can be a misconfiguration but also and error in k2 module

thank you for your attention,

Ana Lázaro

Please Log in or Create an account to join the conversation.

  • guida
  • guida's Avatar Topic Author
  • Offline
  • Junior Member
More
3 weeks 6 days ago #177721 by guida
Replied by guida on topic Font End Users menu not displays properly
users report this error in their pages:

Notice: Undefined offset: 1 in /home/skillyou/public_html/plugins/system/k2/k2.php on line 702

this is not the template

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Offline
  • Administrator
  • JoomlaWorks Support Team
More
3 weeks 8 hours ago #177757 by Fotis
Replied by Fotis on topic Font End Users menu not displays properly
Try v2.10.4 (dev) from: getk2.org/downloads/?f=K2_Development_Release.zip

Should resolve your issue.

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

  • guida
  • guida's Avatar Topic Author
  • Offline
  • Junior Member
More
2 weeks 6 days ago #177797 by guida
Replied by guida on topic Font End Users menu not displays properly
Yes, it does.thank you

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Offline
  • Administrator
  • JoomlaWorks Support Team
More
2 weeks 6 days ago #177801 by Fotis
Replied by Fotis on topic Font End Users menu not displays properly
Great.

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.


Powered by Kunena Forum