Keyword

Month mismatch in archive month display

  • Paul Srch
  • Paul Srch's Avatar Topic Author
  • Offline
  • Junior Member
More
1 month 3 weeks ago #178773 by Paul Srch
Replied by Paul Srch on topic Month mismatch in archive month display
Hmmm...Since it's dong the same thing on two different websites (on the same server) - is it possible some server setting is causing this? The newest site is just a test bed for K2, and the only thing it has installed is in fact K2. If it could be something server-related, any idea what I could have my hosting provider check for?

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Away
  • Administrator
  • JoomlaWorks Support Team
More
1 month 3 weeks ago - 1 month 3 weeks ago #178780 by Fotis
Replied by Fotis on topic Month mismatch in archive month display
It's surely server related. Ask them to double-check the timezone set for the server itself and if there is any customization for the timezone in PHP and/or MySQL/MariaDB.

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member
Last edit: 1 month 3 weeks ago by Fotis.

Please Log in or Create an account to join the conversation.

  • Paul Srch
  • Paul Srch's Avatar Topic Author
  • Offline
  • Junior Member
More
1 month 3 weeks ago #178786 by Paul Srch
Replied by Paul Srch on topic Month mismatch in archive month display
And of course, just to make things more interesting... one of the sites I host uses WordPress, and check out what happens when you go to the Archive and select a particular month: www.wherefaithmeetslife.com/

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Away
  • Administrator
  • JoomlaWorks Support Team
More
1 month 3 weeks ago #178787 by Fotis
Replied by Fotis on topic Month mismatch in archive month display
Each CMS is different. But I like how Joomla exposes what appears to be an issue on your server.

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

  • Paul Srch
  • Paul Srch's Avatar Topic Author
  • Offline
  • Junior Member
More
1 month 1 week ago #178876 by Paul Srch
Replied by Paul Srch on topic Month mismatch in archive month display
OK, I found the issue... at least, I removed some regular Joomla plugins and it's working now. Not sure which plugin was the culprit, but I didn't think anything I had could have messed up K2...

Now, all I need to know is where I can update the CSS so I can adjust some of the look and feel...

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Away
  • Administrator
  • JoomlaWorks Support Team
More
1 month 1 week ago #178880 by Fotis
Replied by Fotis on topic Month mismatch in archive month display
This means that some plugin was enforcing a different time zone which messed up editing entirely (and the dates records in the database were stored).

As for styling K2, use this guide for reference: getk2.org/documentation/tutorials/templating-with-k2-and-the-concepts-of-sub-templates

K2's default CSS can easily be overwritten or entirely switched off (in K2's settings). By making use of sub-template overrides and category parameter inheritance, you'll soon discover the true power of K2 :)

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

  • Paul Srch
  • Paul Srch's Avatar Topic Author
  • Offline
  • Junior Member
More
1 month 1 week ago #178891 by Paul Srch
Replied by Paul Srch on topic Month mismatch in archive month display
I think I'm missing something. IN my understanding, I needed to add a file - /templates/YOURTEMPLATE/css/k2.css to my system, which I did, with the following lines:
Log in  or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Away
  • Administrator
  • JoomlaWorks Support Team
More
1 month 3 days ago #178907 by Fotis
Replied by Fotis on topic Month mismatch in archive month display
It's loaded alright: jmp.sh/QEF0d3i

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

  • Paul Srch
  • Paul Srch's Avatar Topic Author
  • Offline
  • Junior Member
More
1 month 3 days ago #178910 by Paul Srch
Replied by Paul Srch on topic Month mismatch in archive month display
Got it all figured out - thank you SOOOOO much for all your help. I know I've been a pain, but this was really important to me!

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Away
  • Administrator
  • JoomlaWorks Support Team
More
3 weeks 3 days ago #178951 by Fotis
Replied by Fotis on topic Month mismatch in archive month display
The result matters :)

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.