Keyword

German umlauts are displayed wrong

  • forensis
  • forensis's Avatar Topic Author
  • Offline
  • New Member
More
3 weeks 14 hours ago - 3 weeks 11 hours ago #178406 by forensis
German umlauts are displayed wrong was created by forensis
K2 v2.10.3:
If I enter keywords with German umlauts, they are always displayed without umlauts. Example:

Schlagwörter => Schlagworter
Ärger => Arger
Östrogene => Ostrogene
Übersicht => Ubersicht
Straße => Strasse

Where can I set Ä, Ö, Ü and ß to display as Ä, Ö, Ü, ß? Does this require an override or is there a conversion table that I haven't found yet and that doesn't work properly?

K2 does NOT react to "Keyword Normalization> Activate" and the "Additional character replacements":
ä|ae, ö|oe, ü|ue, ß|ss,

What am I doing wrong?

The umlauts work correctly in the native Joomla articles.

Regards, Walter
Last edit: 3 weeks 11 hours ago by forensis.

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Offline
  • Administrator
  • JoomlaWorks Support Team
More
2 weeks 4 days ago #178453 by Fotis
Replied by Fotis on topic German umlauts are displayed wrong
The replacements part you mention is for K2 item URLs.

For tags you can configure replacements as you like under the "Site" tab, sections "Tags" in K2's settings.

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

  • forensis
  • forensis's Avatar Topic Author
  • Offline
  • New Member
More
2 weeks 4 days ago #178463 by forensis
Replied by forensis on topic German umlauts are displayed wrong
After some experimentation, I found out that I have to deactivate the keyword normalization in order to ensure that all umlauts are displayed exactly as entered. I misunderstood that at first. I thought I had to achieve that an Ä becomes an Ae and an Ü becomes an Ue. But apparently that doesn't have to be the case. So normalization deactivated and Ä => Ä!

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Offline
  • Administrator
  • JoomlaWorks Support Team
More
2 weeks 4 days ago #178466 by Fotis
Replied by Fotis on topic German umlauts are displayed wrong
Wunderbar!

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.


Powered by Kunena Forum