Keyword

No inserta la imagen

  • colsaco
  • colsaco's Avatar Topic Author
  • Offline
  • New Member
More
5 years 11 months ago #120936 by colsaco
colsaco created the topic: No inserta la imagen
Hola a todos!
tengo hace un tiempo un problema con los articulos de K2. Pongo una imagen que acompañe, la inserto y cuando doy a guardar, la imagen no queda guardada. Sospecho que es algún tema de permisos en las carpetas, pero estoy un poco perdido...
Además, las imágenes que pongo en los artículos se pixelan mucho ( a pesar de tener correcta la configuracion)..¿Cuál puede ser la causa?
Un saludo

Please Log in or Create an account to join the conversation.

  • Emanuel Rodríguez
  • Emanuel Rodríguez's Avatar
  • Offline
  • Moderator
  • Robustiana.com
More
5 years 11 months ago #120937 by Emanuel Rodríguez
Emanuel Rodríguez replied the topic: Re: No inserta la imagen
¿Cuál es la ruta asignada para guardar la imágenes (según la configuración global? Porque sí, es probable que sea un problema de permisos. Puede que la carpeta a la que subes las imágenes no cuente con los permisos de escritura por lo que debes dárselos. Esto con un gestor FTP, un File Manager para Joomla! o AdminTools entre otras opciones.

Ahora, ¿a que te refieres con " las imágenes que pongo en los artículos"?¿Las imágenes que insertas por medio del editor o las imágenes que asignas desde la pestaña "Imagen"?

Robustiana.com ... Tutoriales, guías de uso y resolución de problemas en Joomla! y K2

Please Log in or Create an account to join the conversation.

  • colsaco
  • colsaco's Avatar Topic Author
  • Offline
  • New Member
More
5 years 10 months ago #120938 by colsaco
colsaco replied the topic: Re: No inserta la imagen
Hola Emanuel y gracias por tu respuesta... Cuando no te funcionan las cosas agrada que alguien te pueda ayudar!!!

Emanuel Rodríguez wrote: ¿Cuál es la ruta asignada para guardar la imágenes (según la configuración global? Porque sí, es probable que sea un problema de permisos. Puede que la carpeta a la que subes las imágenes no cuente con los permisos de escritura por lo que debes dárselos. Esto con un gestor FTP, un File Manager para Joomla! o AdminTools entre otras opciones.

Bueno, creo que la carpeta donde se almacenan las imágenes está en/media/k2/items/cache y esa carpeta la tenái con permisos 755. La he cambiado a 777... Es esto lo que debo hacer??

Ahora, ¿a que te refieres con " las imágenes que pongo en los artículos"?¿Las imágenes que insertas por medio del editor o las imágenes que asignas desde la pestaña "Imagen"?

Me refiero a las imágenes que pongo en la pestaña Imagen. Aunque no pesen mucho, no salen con la definición que la original, y se pixela algo.... He mirado la configuración de imágenes del K2 y creo que está bien. ¿Es normal?


Gracias de nuevo por tu ayuda. Un saludo!

Please Log in or Create an account to join the conversation.

  • Emanuel Rodríguez
  • Emanuel Rodríguez's Avatar
  • Offline
  • Moderator
  • Robustiana.com
More
5 years 10 months ago #120939 by Emanuel Rodríguez
Emanuel Rodríguez replied the topic: Re: No inserta la imagen
Ok, pero no entiendo, ¿si las imágenes que subes no se están guardando como es que las estás viendo "pixeladas"?

Hay que estar seguros de donde está guardando el K2 las imágenes. Y no es necesario dar permisos 777; de hecho eso puede ser contraproducente.

Sobre el "pixeleo", ¿has hecho cambios en el k2.css?

Si pudieras facilitar un link donde se muestre el problema te podría ayudar más.

Robustiana.com ... Tutoriales, guías de uso y resolución de problemas en Joomla! y K2

Please Log in or Create an account to join the conversation.

  • colsaco
  • colsaco's Avatar Topic Author
  • Offline
  • New Member
More
5 years 10 months ago #120940 by colsaco
colsaco replied the topic: Re: No inserta la imagen

Emanuel Rodríguez wrote: Ok, pero no entiendo, ¿si las imágenes que subes no se están guardando como es que las estás viendo "pixeladas"?

Hay que estar seguros de donde está guardando el K2 las imágenes. Y no es necesario dar permisos 777; de hecho eso puede ser contraproducente.

Sobre el "pixeleo", ¿has hecho cambios en el k2.css?

Si pudieras facilitar un link donde se muestre el problema te podría ayudar más.


Gracias Emanuel...Perdona pero no he tenido tiempo de responderte...No me dedico a esto, y a veces no puedo dedicarle el tiempo que querría...

Bueno, he conseguido lo de las imágenes, pero a costa de poner los permisos donde las guarda en 777... Me dices que no es correcto... cómo lo tengo que hacer para tenerlo más seguro??

No, no he hecho cambios en el k2.css. Puede ser que ahí estén los problemas... en el tamaño de la imagen. Ahora mismo me salen unas imágenes muy grandes mientars qeu la que subo es pequeña... No hay forma de que pueda poner el tamaño que subo de la imagen???

Gracias. Te contesto con más tiempo cuiando me digas estas cosas....

Please Log in or Create an account to join the conversation.

  • Emanuel Rodríguez
  • Emanuel Rodríguez's Avatar
  • Offline
  • Moderator
  • Robustiana.com
More
5 years 10 months ago #120941 by Emanuel Rodríguez
Emanuel Rodríguez replied the topic: Re: No inserta la imagen
Hola, me parece que con permisos 755 sería suficiente y más seguro. Si solo con permisos 777 te sube imágenes déjalo así pero no lo considero del todo conveniente.

En cuanto al problema de las imágenes quisiera que facilitaras un enlace donde se evidencie el problema. Si es posible determinar el tamaño de las imágenes de categoría y sub-categoría sin embargo con un enlace te podría ayudar más.

Robustiana.com ... Tutoriales, guías de uso y resolución de problemas en Joomla! y K2

Please Log in or Create an account to join the conversation.

More
4 years 11 months ago #120942 by Armando Rodriguez
Armando Rodriguez replied the topic: Re: No inserta la imagen
yo tengo el mismo problema
mira este es un link de como se pixelea la imagen

www.enfoquedemichoacan.com/index.php/futbol/tercera-division-profesional


y en si la imagen esta de 600x400 px y se ve como de 20px

Please Log in or Create an account to join the conversation.

More
4 years 11 months ago #120943 by Armando Rodriguez
Armando Rodriguez replied the topic: Re: No inserta la imagen
Resolví el problema amigo, bueno en lo personal creo que teníamos el mismo problema

te dejo una imagen del problema que tenia con la solución que implemente y me resultó
yo estaba trabajando en Localhost y decidí subirlo al hosting pero ni asi se elimino el problema entonces realicé estos cambios en local y también en linea para probar y me resultó bien, así que espero sea tu solución también porque es un dolor de cabeza este detalle, saludos.
Attachments:

Please Log in or Create an account to join the conversation.

Moderators: william whiteEmanuel Rodríguez

Powered by Kunena Forum