Keyword

istallazione nuova versione K2 su joomla 3.9....

  • Giuseppe Piffaretti
  • Giuseppe Piffaretti's Avatar Topic Author
  • Offline
  • New Member
More
6 months 1 week ago #174645 by Giuseppe Piffaretti
istallazione nuova versione K2 su joomla 3.9.... was created by Giuseppe Piffaretti
Joomla non installa a causa del seguente errore ( vedi sotto).
Cosa suggerite ?

Grazie
________________________________________________________________

Warning
JInstaller: :Install: Error SQL Index column size too large. The maximum column size is 767 bytes.
Extension Install: SQL error processing query: DB function failed with error number 1709
Index column size too large. The maximum column size is 767 bytes.
SQL =
CREATE TABLE IF NOT EXISTS `#__k2_tags` (
`id` int(11) NOT NULL AUTO_INCREMENT,
`name` varchar(255) NOT NULL,
`published` smallint(6) NOT NULL DEFAULT '0',
PRIMARY KEY (`id`),
KEY `idx_name` (`name`),
KEY `idx_published` (`published`)
) ENGINE=InnoDB DEFAULT CHARSET=utf8mb4 DEFAULT COLLATE=utf8mb4_unicode_ci;
×
Error
Error installing component

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Offline
  • Administrator
  • JoomlaWorks Support Team
More
6 months 1 week ago #174649 by Fotis
What is your MySQL version?

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

  • Giuseppe Piffaretti
  • Giuseppe Piffaretti's Avatar Topic Author
  • Offline
  • New Member
More
6 months 1 week ago #174651 by Giuseppe Piffaretti
Replied by Giuseppe Piffaretti on topic istallazione nuova versione K2 su joomla 3.9....
MySQL 5.6

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Offline
  • Administrator
  • JoomlaWorks Support Team
More
6 months 4 days ago #174666 by Fotis
The problem is probably related to your MySQL (or MariaDB) configuration. To be exact and as described here dev.mysql.com/doc/refman/5.7/en/innodb-limits.html if "innodb_large_prefix" is set to false, this limit is imposed to databases with utf8mb4_unicode_ci collation.

Your hosting company may have set this option explicitly for backwards compatibility reasons (the default is enabled).

The other option is to download and extract the K2 zip file and edit the file /administrator/components/com_k2/install.mysql.sql replacing all instances of "CHARSET=utf8mb4 DEFAULT COLLATE=utf8mb4_unicode_ci" with "CHARSET=utf8 DEFAULT COLLATE=utf8_general_ci". Then repackage the contents you extracted into a new zip file and finally install that file in Joomla.

If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.


Powered by Kunena Forum