Keyword

Bug: Using custom module chrome with SRFR

  • LearningByDoing
  • LearningByDoing's Avatar Topic Author
  • Offline
  • New Member
More
5 years 7 months ago #54462 by LearningByDoing
LearningByDoing created the topic: Bug: Using custom module chrome with SRFR
I was trying to use custom module chrome ("/templates/MYTEMPLATE/html/modules.php") with Simple RSS Feed Reader, but the module did not detect the custom file. Instead the module content was displayed without any chrome at all (that is the "moduletable" class div and headline, that's usually wrapped around the module output). The custom module chrome worked with other modules though.

I was able to track the problem down and found a bugfix that requires core file modification. In file "modules/mod_jw_srfr/mod_jw_srfr.php", rename the variable "$template" in lines 34 and 66 (I simply chose the name $template2). Otherwise Joomla confuses the name of the SRFR template withe the name of the Joomla template and builds a non-existing URL (in file "/libraries/cms/module/helper.php", function "renderModule").

I hope this helps the developers as well as people who get the same error.

(Joomla 3.2.1, Simple RSS Feed Reader 3.0)

Please Log in or Create an account to join the conversation.

  • Yiota
  • Yiota's Avatar
  • Visitor
5 years 7 months ago #54463 by Yiota
Yiota replied the topic: Re: Bug: Using custom module chrome with SRFR
Hello and thank you for sharing this.

Please Log in or Create an account to join the conversation.

  • LearningByDoing
  • LearningByDoing's Avatar Topic Author
  • Offline
  • New Member
More
5 years 7 months ago #54464 by LearningByDoing
LearningByDoing replied the topic: Re: Bug: Using custom module chrome with SRFR
You're welcome. :)

Please Log in or Create an account to join the conversation.

  • LearningByDoing
  • LearningByDoing's Avatar Topic Author
  • Offline
  • New Member
More
4 years 1 week ago #146557 by LearningByDoing
LearningByDoing replied the topic: Bug: Using custom module chrome with SRFR
Hi,

Sorry for reactivating this old topic, but...

I just updated SRFR to version 3.3 and ran into strange problems. Fortunately I remembered there had been an issue with custom module chrome. Unfortunately the old bug described in the initial post is still present. I hope you find the time to implement a fix with your next update.

(Joomla 3.4.3, Simple RSS Feed Reader 3.3)

Please Log in or Create an account to join the conversation.

More
4 years 1 week ago - 4 years 1 week ago #146562 by Krikor Boghossian
Krikor Boghossian replied the topic: Bug: Using custom module chrome with SRFR
Thank you for your feedback.
It will be changed in the next version.

In the meantime you can get the latest dev release from: github.com/joomlaworks/simple-rss-feed-reader (use the "Download ZIP" button on the right column)

IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

---
JoomlaWorks
www.joomlaworks.net/
Last edit: 4 years 1 week ago by Fotis.

Please Log in or Create an account to join the conversation.


Powered by Kunena Forum