Keyword

No posts in frontend

  • Sammenslutningen ved Storaa
  • Sammenslutningen ved Storaa's Avatar Topic Author
  • Offline
  • New Member
More
3 years 6 months ago - 3 years 6 months ago #151084 by Sammenslutningen ved Storaa
Sammenslutningen ved Storaa created the topic: No posts in frontend
From Joomla 3.4.8 extentions I have installed Simple RSS Feed Reader. It worked well with the original URL's

Then I tryed to get posts from this feed I have made: eu.jotform.com/rss/60035043678049

I only got this in frontend:
Warning: fopen(): Filename cannot be empty in /home/.../svstoraa.dk/public_html/libraries/joomla/filesystem/file.php on line 330
Warning: Invalid argument supplied for foreach() in /home/.../svstoraa.dk/public_html/modules/mod_jw_srfr/helper.php on line 42
Warning: Invalid argument supplied for foreach() in /home/.../svstoraa.dk/public_html/modules/mod_jw_srfr/helper.php on line 42

From another thread in this forum I learned to remowe all "space", "enter" or "lineshift" from the URL field

This solved some of the problem, but I still got this in frontend:
Warning: Invalid argument supplied for foreach() in /home/.../svstoraa.dk/public_html/modules/mod_jw_srfr/helper.php on line 42

From another thread in this forum I got the advice to update via this link:
github.com/joomlaworks/simple-rss-feed-reader/archive/master.zip

Now all the warnings are gone, but I get no posts in frontend.

Again I have tryed out the original feeds, and also some other feeds, which all are working OK.

So what do I do now?
Last edit: 3 years 6 months ago by Sammenslutningen ved Storaa. Reason: Removing exact names

Please Log in or Create an account to join the conversation.

More
3 years 6 months ago #151097 by Lefteris
Lefteris replied the topic: No posts in frontend
Hi,

There is an error thrown by the XML parser:Failed loading XML attributes construct error Couldn't find end of Start Tag rss line 1 Extra content at the end of the document.

Looking at the feed you provided it looks like the extra whitespace at the root RSS tag is causing the issue.

IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

---
JoomlaWorks
www.joomlaworks.net/

Please Log in or Create an account to join the conversation.

  • Sammenslutningen ved Storaa
  • Sammenslutningen ved Storaa's Avatar Topic Author
  • Offline
  • New Member
More
3 years 6 months ago #151124 by Sammenslutningen ved Storaa
Sammenslutningen ved Storaa replied the topic: No posts in frontend
I have given Your information to the people at JotFrom. Let's se if they can do anything about it.

Funny though, the RSS feed from JotForm does work with the built in RSS reader in Joomla 3.x, but this feature do not have the opportunity to hide feed item title or date and time.

Here You can see how the built in reader works:

http://imgur.com/iTydpEH

Please Log in or Create an account to join the conversation.

More
3 years 4 months ago #153432 by Wojtowicz Nicolas
Wojtowicz Nicolas replied the topic: No posts in frontend
Hi,

I have the same problem with some RSS feed ( an error 'XML parser:Failed loading XML attributes construct error Couldn't find end of Start Tag...' ) but these feeds work with other readers ( for example with newsfox).

Where comes this error, from joomla itself or from the module 'Simple RSS Feed Reader'?

Thanks.

Nicolas

Please Log in or Create an account to join the conversation.

More
3 years 4 months ago #153435 by Krikor Boghossian
Krikor Boghossian replied the topic: No posts in frontend
Where are you getting this error exacty.
Simple RSS Feed Reader requires valid feeds in order to work properly.

IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

---
JoomlaWorks
www.joomlaworks.net/

Please Log in or Create an account to join the conversation.

More
3 years 4 months ago #153436 by Wojtowicz Nicolas
Wojtowicz Nicolas replied the topic: No posts in frontend
It comes right after trying to display the RSS feed

this is an example of feed:
arc-copro.fr/taxonomy/term/73/feed

It works with Newsfox reader ( on firefox) but not with Simple RSS ( and what a pity because I really like this extension)

Please Log in or Create an account to join the conversation.

More
3 years 4 months ago #153444 by Wojtowicz Nicolas
Wojtowicz Nicolas replied the topic: No posts in frontend
I saw that the string with the rss feed is rejected by the function simplexml_load_string, the original feed must a bit malformed, is there a way to clean up the string ?

Please Log in or Create an account to join the conversation.

More
3 years 4 months ago #153507 by Krikor Boghossian
Krikor Boghossian replied the topic: No posts in frontend
This is an invalid feed -> validator.w3.org/feed/check.cgi?url=http%3A%2F%2Farc-copro.fr%2Ftaxonomy%2Fterm%2F73%2Ffeed

You can try adding this feed into a feedburner feed (I do not know if the service is still online) to ensure that the feed is valid.

IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

---
JoomlaWorks
www.joomlaworks.net/

Please Log in or Create an account to join the conversation.

More
3 years 4 months ago #153529 by Wojtowicz Nicolas
Wojtowicz Nicolas replied the topic: No posts in frontend
OK, Thanks for your answer, I will try that.

Nicolas

Please Log in or Create an account to join the conversation.


Powered by Kunena Forum