Keyword

K2 Media Manager not showing pictures

  • Fotis
  • Fotis's Avatar
  • Offline
  • Administrator
  • JoomlaWorks Support Team
More
8 months 2 weeks ago #169393 by Fotis
Fotis replied the topic: K2 Media Manager not showing pictures
Noted to check. Thank you.


If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

More
8 months 2 weeks ago #169480 by Calhoun357
Calhoun357 replied the topic: K2 Media Manager not showing pictures
There is a problem in adding images frontend
If I use the frontend to create or add an item and want to add images.
I get some confusing window, where I should be able to select images.
The only thing you can do is close the popup window.
I do not get this using the backend.

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Offline
  • Administrator
  • JoomlaWorks Support Team
More
8 months 2 weeks ago #169484 by Fotis
Fotis replied the topic: K2 Media Manager not showing pictures
Make a few screenshots of what you see.


If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

More
8 months 2 weeks ago #169489 by Calhoun357
Calhoun357 replied the topic: K2 Media Manager not showing pictures

Calhoun357 wrote: There is a problem in adding images frontend
If I use the frontend to create or add an item and want to add images.
I get some confusing window, where I should be able to select images.
The only thing you can do is close the popup window.
I do not get this using the backend.


Hi there,

I am having a issue in adding images on frontend... I am looking for a guidance or a support... Any expert here???
Please reply

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Offline
  • Administrator
  • JoomlaWorks Support Team
More
8 months 1 week ago #169498 by Fotis
Fotis replied the topic: K2 Media Manager not showing pictures
You have to be more specific. Provide screenshots.


If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

More
2 months 1 week ago #171685 by Darren Forster
Darren Forster replied the topic: K2 Media Manager not showing pictures
I've had this same problem for months now - it even has the same problem if you install a new site so it seems the developers haven't noticed the bug yet.

There is a simple solution to fix this...

Go into the file manager for your site (via cpanel or something) and go into the root folder of your Joomla installation (normally /public_html/ depending on how your site is set up).

in there go into media/k2/assets/vendors/studio-42

once your in the studio-42 folder you'll see two folders - one called "elFinder" and the other called "elfinder.1" rename elfinder.1 to elfinder (make sure it's all lower case - Linux servers are case sensitive).

You should now have two folders in there one called elfinder and one called elFinder - you can either leave the elFinder folder in there or get rid of it - it's up to you - I left it there 'cos it doesn't appear to be doing any harm.

Go back into Joomla and browse for media on the server and your media browser should now be working.

Looking at the bug what I would say has happened is somewhere along the line someone has changed the elfinder plug in and I get the feeling that they might have been on a Windows system or some other system that doesn't bother about case in filenames - Windows is not case sensitive when it comes to folder names so elfinder and elFinder would be the same and so somewhere along the lines the new version of elfinder has been renamed to .1 however on a Linux server elfinder and elFinder is not the same and so according to the server elfinder doesn't exist - it seems the elfinder.1 folder has all the bits needed like the css and everything, where as elFinder only has a selection of files which is why I guess that elFinder is either the incomplete version or the old version.

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Offline
  • Administrator
  • JoomlaWorks Support Team
More
2 months 4 days ago #171742 by Fotis
Fotis replied the topic: K2 Media Manager not showing pictures
If you install K2 v2.9.1 (dev) from K2's GitHub repo github.com/getk2/k2/archive/master.zip it will resolve this issue. So the issue is fixed for the next release.


If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

More
2 months 1 day ago #171796 by Paul Zaal
Paul Zaal replied the topic: K2 Media Manager not showing pictures
Thnx for this.
Works like a charm now.

Many regards!!

Please Log in or Create an account to join the conversation.

  • Fotis
  • Fotis's Avatar
  • Offline
  • Administrator
  • JoomlaWorks Support Team
More
2 months 1 day ago #171805 by Fotis
Fotis replied the topic: K2 Media Manager not showing pictures
You're welcome.


If you use & love K2, please take a moment to add your review and rate it
at the Joomla Extensions Directory: extensions.joomla.org/extension/k2/


IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

More
1 month 2 weeks ago - 1 month 2 weeks ago #171924 by Railer
Railer replied the topic: K2 Media Manager not showing pictures
Is this master.zip file for K2 2.9.0 still? More importantly, why is there a duplicate elFinder.1 directory?
Thanks
Btw, I tried changing the directory name of elFinder.1 to elFinder and deleting the original and it worked, but I see that the contents of them differs.
Last edit: 1 month 2 weeks ago by Railer.

Please Log in or Create an account to join the conversation.

Moderators: william white

Powered by Kunena Forum