IMPORTANT MESSAGE REGARDING THE FORUM

As you may already know, the JoomlaWorks Forum is powered by Kunena (the only decent forum component for Joomla).

Unfortunately, the latest update for Kunena has seemingly broken all code snippets (old and new) in the forum.

Until this message is removed, please paste any code as regular text - in other words, don't use the [code]...[/code] tags in Kunena's post editor.

Keyword

Media Manager Error: Invalid backend response. Data is not JSON.

  • Terry Pierce
  • Terry  Pierce's Avatar Topic Author
  • Offline
  • New Member
More
1 year 11 months ago #172985 by Terry Pierce
Hello - I'm getting this error when trying to use the Media Manager:

Invalid backend response.
Data is not JSON.
The most recent request was denied because it had an invalid security token. Please refresh the page and try again.

I'm running the most recent Joomla & K2 versions and have tried disabling error reporting but still get the message.
Any other recommendations would be appreciated!

Please Log in or Create an account to join the conversation.

  • Terry Pierce
  • Terry  Pierce's Avatar Topic Author
  • Offline
  • New Member
More
1 year 11 months ago #172999 by Terry Pierce
^ Bump ^

Please Log in or Create an account to join the conversation.

More
1 year 11 months ago #173018 by Fotis
If some system plugin is not throwing a PHP warning in raw Joomla outputs (which K2 uses for outputting JSON), try updating to K2 v2.10 (dev) from: github.com/getk2/k2/archive/master.zip

In any case, open your browser's dev tools console and check the errors displayed...

IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

More
2 months 3 weeks ago - 2 months 3 weeks ago #178857 by Thomas Thrane
Hi

I'm starting to get this error too and I'm on K2 v2.10.3
Any advice?

The only error I get is:
Missing: www.sawo.dk/da/administrator/css/theme.css

Regards
Thomas
Last edit: 2 months 3 weeks ago by Thomas Thrane.

Please Log in or Create an account to join the conversation.

More
2 months 3 weeks ago #178869 by Fotis
Switch error reporting to "none" in Joomla's Global Configuration. Does the issue still occur?

IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

More
2 months 3 weeks ago #178884 by Thomas Thrane
Yes it does - and I have cleared the cache completely.

Please Log in or Create an account to join the conversation.

More
2 months 2 weeks ago #178905 by Fotis
The error you mentioned is not really an error though, nor is it related to K2.

You need to open up your browser's dev tools, switch to the Network and then perform any actions. There you should see the AJAX actions of the file manager and in there you'll spot the issue.

IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

Please Log in or Create an account to join the conversation.

More
2 months 1 week ago #178926 by Thomas Thrane
Thanks!
So it's the last line, that causes the issue?

 
Attachments:

Please Log in or Create an account to join the conversation.

More
2 months 1 week ago #178933 by Thomas Thrane
I don't get more errors than the above mentioned, and that error I see on every site I make, but not the JSON error :-(

Please Log in or Create an account to join the conversation.

More
2 months 1 week ago #178934 by Thomas Thrane
We get an invalid backend response when trying to access the MediaManager

The error happens in this request: /administrator/index.php?option=com_k2&view=media&task=connector&ff86b844a34b8546e70305cf82b5b429=1&cmd=open&target=&init=1&tree=1&_=1621427068790

Accessing this URL directly in the browser with an active admin session, responds with the following errormessage: "The most recent request was denied because it had an invalid security token. Please refresh the page and try again."

At the same time we get errors in PHP error log:
[19-May-2021 16:30:28 Europe/Copenhagen] PHP Notice: Trying to get property 'alias' of non-object in D:\wwwroot\components\com_k2\router.php on line 292
[19-May-2021 16:30:28 Europe/Copenhagen] PHP Notice: Trying to get property 'id' of non-object in D:\wwwroot\components\com_k2\router.php on line 316

Site is running on IIS 10, Windows 2019
PHP version: 7.4.16 NTS
K2 version: 2.10.3
Joomla version: Joomla! 3.9.26 Stable [ Amani ] 13-April-2021 15:00 GMT
MySql database version: 8.0.19

Please advise.

Please Log in or Create an account to join the conversation.


Powered by Kunena Forum