Support will be in summer mood from 6-17 August, 2018 while the JoomlaWorks folks get some rest.
Keyword
Please note that official support for commercial extensions & templates is provided in the Subscriber Help Desk.
Support requests should ONLY be directed there and require an active subscription plan.
This forum board is to be used for archive purposes and knowledge exchange ONLY.

Facebook Login no longer working...

  • Aaron M. Bielert
  • Aaron M. Bielert's Avatar Topic Author
  • Offline
  • New Member
More
3 months 3 days ago #167896 by Aaron M. Bielert
Aaron M. Bielert created the topic: Facebook Login no longer working...
I know my subscription expired a few months ago, but Facebook is no longer working on my site, it keeps saying URI does not match site. This started a few weeks ago I’m guessing after Facebook started changing its privacy stuff. I’m still using 1.8.1 and wondering if I need to renew my subscription to download a newer version or if there is an easy fix for this?
This message contains confidential information

Please Log in or Create an account to join the conversation.

  • Aaron M. Bielert
  • Aaron M. Bielert's Avatar Topic Author
  • Offline
  • New Member
More
3 months 3 days ago #167897 by Aaron M. Bielert
Aaron M. Bielert replied the topic: Facebook Login no longer working...
Wanted to go ahead and update this. I figured it out and the docs should be updated accordingly. The URI must match the site now exactly and this is the URI that should be used when using Social Connect.
https://www.YOUR_SITE.com/index.php?option=com_socialconnect&view=login&task=facebookoauth

Please Log in or Create an account to join the conversation.

More
3 months 3 days ago #167907 by Krikor Boghossian
Krikor Boghossian replied the topic: Facebook Login no longer working...
Thank you for pointing out the solution Aaron.

IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

---
JoomlaWorks
www.joomlaworks.net/

Please Log in or Create an account to join the conversation.

More
1 month 2 days ago #168511 by Udi
Udi replied the topic: Facebook Login no longer working...
Hi,
I'm in the same situation.

What should be the link if we use URL friendly and rewrite while index.php is not part of the path?

thank you
Udi

Please Log in or Create an account to join the conversation.

More
1 month 2 days ago #168514 by Krikor Boghossian
Krikor Boghossian replied the topic: Facebook Login no longer working...
Hello Udi,
No reason to alter the URL, even if SEF URLs are being used, these URLs still resolve to the correct path.

IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

---
JoomlaWorks
www.joomlaworks.net/

Please Log in or Create an account to join the conversation.

More
1 month 9 hours ago #168537 by Udi
Udi replied the topic: Facebook Login no longer working...
Hi Krikor,

I don't succeed make it working for a while ...

Socialconnect overrides J!
For Registration I use RSForm because I need more details during registration.
So I redirects index.php/component/socialconnect/login to my homepage.

Should I add that one - index.php/component/socialconnect/login - to facebook authentication?

thank you
Udi

Please Log in or Create an account to join the conversation.

More
1 month 6 hours ago #168539 by Krikor Boghossian
Krikor Boghossian replied the topic: Facebook Login no longer working...
Can you send me Super User Access in a ticket in the helpdesk so I can take a look?
Also use the full path yourdomain.com/ index.php/component/socialconnect/login as well.

IMPORTANT: Please search the forum before posting a question!

JoomlaWorks Support Team Member

---
JoomlaWorks
www.joomlaworks.net/

Please Log in or Create an account to join the conversation.